POJ 1469 COURSES

COURSES
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 14191 Accepted: 5614

Description

Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is to determine whether it is possible to form a committee of exactly P students that satisfies simultaneously the conditions:

  • every student in the committee represents a different course (a student can represent a course if he/she visits that course)
  • each course has a representative in the committee

Input

Your program should read sets of data from the std input. The first line of the input contains the number of the data sets. Each data set is presented in the following format:

P N
Count1 Student 1 1 Student 1 2 ... Student 1 Count1
Count2 Student 2 1 Student 2 2 ... Student 2 Count2
...
CountP Student P 1 Student P 2 ... Student P CountP

The first line in each data set contains two positive integers separated by one blank: P (1 <= P <= 100) - the number of courses and N (1 <= N <= 300) - the number of students. The next P lines describe in sequence of the courses �from course 1 to course P, each line describing a course. The description of course i is a line that starts with an integer Count i (0 <= Count i <= N) representing the number of students visiting course i. Next, after a blank, you抣l find the Count i students, visiting the course, each two consecutive separated by one blank. Students are numbered with the positive integers from 1 to N.
There are no blank lines between consecutive sets of data. Input data are correct.

Output

The result of the program is on the standard output. For each input data set the program prints on a single line "YES" if it is possible to form a committee and "NO" otherwise. There should not be any leading blanks at the start of the line.

Sample Input

2
3 3
3 1 2 3
2 1 2
1 1
3 3
2 1 3
2 1 3
1 1

Sample Output

YES
NO

Source

Southeastern Europe 2000

解题思路:这一题我用的是二分图的最大匹配,套匈牙利算法的模板,若最终所有课程均有学生去上,则输出YES,否则输出NO.需要注意两点:一是课程数貌似超过100,所以数组要开大,我开200的时候还是RE,最后直接开400;二是这一题的输入输出要用scanf和printf,用cin和cout会超时。

#include<stdio.h>
#include <string.h>
int map[400][400],used[400];
int N,P,pre[400];
int find(int x)
{
	int i;
	for(i=1;i<=N;i++)
	{
		if(!used[i]&&map[x][i])//若这门课没有人选且该学生愿意选这门课
		{
			used[i]=1;//这门课设为有人选状态
			if(pre[i]==-1||find(pre[i]))
            //若该学生没有选课或者该学生已选的那门课可以由其他人代替去上
			{
				pre[i]=x;//该生改为上这门课,否则改由其他学生上这门课
				return 1;
			}
		}
	}
	return 0;
}
int MMG()
{
	int i,count=0;
	memset(pre,-1,sizeof(pre));
	for(i=1;i<=P;i++)
	{
		memset(used,0,sizeof(used));//每次考虑下一门课程之前让课程初始化为没有人选
		if(find(i))//若该课程可以安排学生则配对数加1
			count++;
	}
	return count;
}
int main()
{
	int i,j,num,test,person;
	scanf("%d", &test);
	while(test--)
	{
		memset(map,0,sizeof(map));
		scanf("%d%d", &P, &N); 
		for(i=1;i<=P;i++)
		{
			scanf("%d", &num);
			for(j=0;j<num;j++)
			{
				scanf("%d", &person);
				map[i][person]=1;
			}
		}
		//若最终配对数等于课程数,即所有课均有人上,则输出YES,否则输出NO
		if(MMG()==P)
			printf("YES\n");
		else
			printf("NO\n"); 
	    }
		return 0;
}


另外这道题可以改编为问是否所有学生都有课上,本题应该和POJ 1274对照看有利于掌握匈牙利算法。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值