POJ 1423 Big Number

Big Number
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 22741 Accepted: 7257

Description

In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.

Input

Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 <= m <= 10^7 on each line.

Output

The output contains the number of digits in the factorial of the integers appearing in the input.

Sample Input

2
10
20

Sample Output

7
19

Source

Dhaka 2002

解题思路:知道Stirling公式的大神就直接秒这一题吧,但是还有另外一个公式可以做出这道题:len(n!)=log(1)+log(2)+...+log(n)+1;

证明:设n!的位数为k,则n!=a×10^k(0<a<1);

对两边取对数log(n!)=log(a)+k;

即k=log(n)+log(n-1)+log(n-2)+...+log(1)-log(a);

a的进一步范围是0.1<a<1;

因为log(a)是整数,取a=0.1,log(a)=-1;

最终n!=sum(log(i),i=1,2,...,n)+1;

最后打表就可以了。

#include<iostream>
#include<cmath>
using namespace std;
long ans[10000001]={0};
int main()
{
	long m;
	double i,temp;
	int n;
	temp=0.0;
		for(i=1.0;i<10000001;i++)
		    {
				temp+=log10(i);
		        ans[int(i)]=int(temp)+1;
		    }
		cin>>n;
	while(n--)
	{
		cin>>m;
		cout<<ans[m]<<endl;
	}
	return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值