POJ2318 TOYS 计算几何+思维叉积

这篇博客介绍了如何解决一个计算机科学问题,即在一个带有隔板的矩形玩具箱中计算每个隔间内玩具的数量。给定隔板的位置和玩具的坐标,通过叉积判断玩具所属的区间,使用二分查找优化效率。代码实现采用C++,展示了如何有效地进行区间判断和计数。
摘要由CSDN通过智能技术生成

POJ原址链接:POJ2318 TOYS
牛客上的链接:TOYS

Description

Calculate the number of toys that land in each bin of a partitioned toy box.
Mom and dad have a problem - their child John never puts his toys away when he is finished playing with them. They gave John a rectangular box to put his toys in, but John is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for John to find his favorite toys.

John’s parents came up with the following idea. They put cardboard partitions into the box. Even if John keeps throwing his toys into the box, at least toys that get thrown into different bins stay separated. The following diagram shows a top view of an example toy box.
在这里插入图片描述

For this problem, you are asked to determine how many toys fall into each partition as John throws them into the toy box.

Input

The input file contains one or more problems. The first line of a problem consists of six integers, n m x1 y1 x2 y2. The number of cardboard partitions is n (0 < n <= 5000) and the number of toys is m (0 < m <= 5000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1,y1) and (x2,y2), respectively. The following n lines contain two integers per line, Ui Li, indicating that the ends of the i-th cardboard partition is at the coordinates (Ui,y1) and (Li,y2). You may assume that the cardboard partitions do not intersect each other and that they are specified in sorted order from left to right. The next m lines contain two integers per line, Xj Yj specifying where the j-th toy has landed in the box. The order of the toy locations is random. You may assume that no toy will land exactly on a cardboard partition or outside the boundary of the box. The input is terminated by a line consisting of a single 0.

Output

The output for each problem will be one line for each separate bin in the toy box. For each bin, print its bin number, followed by a colon and one space, followed by the number of toys thrown into that bin. Bins are numbered from 0 (the leftmost bin) to n (the rightmost bin). Separate the output of different problems by a single blank line.

Sample Input

5 6 0 10 60 0
3 1
4 3
6 8
10 10
15 30
1 5
2 1
2 8
5 5
40 10
7 9
4 10 0 10 100 0
20 20
40 40
60 60
80 80
5 10
15 10
25 10
35 10
45 10
55 10
65 10
75 10
85 10
95 10
0

Sample Output

0: 2
1: 1
2: 1
3: 1
4: 0
5: 1

0: 2
1: 2
2: 2
3: 2
4: 2
Hint

As the example illustrates, toys that fall on the boundary of the box are “in” the box.
Source

Rocky Mountain 2003

题意

一个矩形左上角为(x1,y1),右下角为(x2,y2),被划分成n+1个区域;n次输出每个区域边界连线上顶点的横坐标 U i U_i Ui和下顶点的横坐标 L i L_i Li ;m次输入一个玩具的坐标;最终输出每个区域内的玩具的个数。

题解

设该点为p(x,y),求p与各个边界连接的向量做叉积(由叉积的政府可判断向量的相对顺逆时针方向),如为负,则证明p与上顶点的向量位于p与下顶点的向量的逆时针方向,符合在该区间中,二分不断缩小直到符合的唯一区间。

//#pragma GCC optimize(2)
//#include<bits/stdc++.h> 
#include <iostream>
#include <stdio.h>
#include <algorithm>
#include <vector>
using namespace std;
#define ll long long
#define endl "\n"
const int MAX=1e6+7;
struct Point{
	int x,y;
	Point(){};
	Point(int tx,int ty):x(tx),y(ty){};
	Point operator-(Point b){
		return Point(x-b.x,y-b.y);
	}
}p;
double Cross(Point a,Point b){
	return a.x*b.y-a.y*b.x;
}
struct Line{
	Point a,b;
	Line(){};
	Line(Point ta,Point tb):a(ta),b(tb){};
};
int n,m,x1,y1,x2,y2,Ui,Li;
int tx,ty,l,r,tmp,mid,f;
int main(){
    ios_base::sync_with_stdio(0);cin.tie(0);
	while(cin>>n){
		if(n==0)break;
		vector<Line>line(n+1);
		vector<ll>ans(n+1);
		cin>>m>>x1>>y1>>x2>>y2;
		for(int i=0;i<n;i++){
			cin>>Ui>>Li;
			line[i]=Line(Point(Ui,y1),Point(Li,y2));
		}
		line[n]=Line(Point(x2,y1),Point(x2,y2));
		while(m--){
			cin>>tx>>ty;
			p=Point(tx,ty);
			l=0,r=n;
			while(l<=r){
				mid=(l+r)/2;
				if(Cross(p-line[mid].a,p-line[mid].b)<0){
					tmp=mid; r=mid-1;
				}
				else l=mid+1;
			}
			ans[tmp]++;
		}
		for(int i=0;i<=n;i++)cout<<i<<": "<<ans[i]<<endl;
		cout<<endl;
	}
   return 0;
} 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值