HDU-1071 The area

1 篇文章 0 订阅

Problem Description
Ignatius bought a land last week, but he didn’t know the area of the land because the land is enclosed by a parabola and a straight line. The picture below shows the area. Now given all the intersectant points shows in the picture, can you tell Ignatius the area of the land?

Note: The point P1 in the picture is the vertex of the parabola.

这里写图片描述

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains three intersectant points which shows in the picture, they are given in the order of P1, P2, P3. Each point is described by two floating-point numbers X and Y(0.0<=X,Y<=1000.0).

Output
For each test case, you should output the area of the land, the result should be rounded to 2 decimal places.

Sample Input
2
5.000000 5.000000
0.000000 0.000000
10.000000 0.000000
10.000000 10.000000
1.000000 1.000000
14.000000 8.222222

Sample Output
33.33
40.69

题意:求阴影部分的面积,中学数学题…图像看成y=-a(x-b)^2+d 就简单很多了,直接贴代码了…..

AC代码:

#include <iostream>
#include <cstring>
#include <string>
#include <cstdio>
#include <cmath>
#include <algorithm>
using namespace std;

#define LL long long

//图像可以表示为:y=-a(x-b)^2+d
double ans(double a,double b,double d,double x1,double x2)
{
    return (-a/3.0*x1*x1*x1+a*b*x1*x1-a*b*b*x1+d*x1)-(-a/3.0*x2*x2*x2+a*b*x2*x2-a*b*b*x2+d*x2);
}

double trapezium(double x1,double y1,double x2,double y2)//P2,P3梯形面积
{
    return (x2-x1)*(y1+y2)/2.0;
}

int main()
{
    int T;
    double a,b,d,x1,x2,y1,y2;
    while(cin>>T)
    {
        while(T--)
        {
            cin>>b>>d;
            cin>>x1>>y1;
            cin>>x2>>y2;
            a=(d-y1)/((x1-b)*(x1-b));
            printf("%.2lf\n",fabs(ans(a,b,d,x1,x2))-fabs(trapezium(x1,y1,x2,y2)));
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

算法之旅

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值