poj 2392 多重背包

Space Elevator
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 8877 Accepted: 4209

Description

The cows are going to space! They plan to achieve orbit by building a sort of space elevator: a giant tower of blocks. They have K (1 <= K <= 400) different types of blocks with which to build the tower. Each block of type i has height h_i (1 <= h_i <= 100) and is available in quantity c_i (1 <= c_i <= 10). Due to possible damage caused by cosmic rays, no part of a block of type i can exceed a maximum altitude a_i (1 <= a_i <= 40000). 

Help the cows build the tallest space elevator possible by stacking blocks on top of each other according to the rules.

Input

* Line 1: A single integer, K 

* Lines 2..K+1: Each line contains three space-separated integers: h_i, a_i, and c_i. Line i+1 describes block type i.

Output

* Line 1: A single integer H, the maximum height of a tower that can be built

Sample Input

3
7 40 3
5 23 8
2 52 6

Sample Output

48

Hint

OUTPUT DETAILS: 

From the bottom: 3 blocks of type 2, below 3 of type 1, below 6 of type 3. Stacking 4 blocks of type 2 and 3 of type 1 is not legal, since the top of the last type 1 block would exceed height 40.

Source

USACO 2005 March Gold

首先对于k种block,每种都有限制高度ai。 假设ai<aj,假如最后是由第i种和第j种block组成的,那么同样的组合第i种的block肯定是放下面最好。所以先对k种物品进行排序。k种物品所能达到的最大高度由前k-1种所能达到的得到。 dp[k][h] -> {dp[k-1][h-c*h[k]]},另外可以用滚动数组优化空间。


#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>

using namespace std;

#define maxk 401
#define maxa 40001

int dp[maxa];
struct node
{
    int h,c,a;
    bool operator < (const node &b) const
    {
        return a < b.a;
    }
}v[maxk];


int main()
{
    int k;
    while(~scanf("%d", &k)){
        for(int i = 1; i <= k; i++)
            scanf("%d%d%d", &v[i].h, &v[i].a, &v[i].c);
        sort(v+1, v+k+1);

        memset(dp, 0, sizeof(dp));
        dp[0] = 1;
        for(int i = 1; i <= k; i++)
        for(int j = v[i].a; j >= 0; j--)
        for(int t = 0; t*v[i].h <= j && t <= v[i].c && !dp[j]; t++)
            dp[j] = dp[j-t*v[i].h];

        int ans;
        for(int i = v[k].a; i >= 0; i--)
        if(dp[i]){
            ans = i;
            break;
        }

        printf("%d\n", ans);
    }
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值