02-线性结构3 Reversing Linked List (25分)

题目

Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given L being 1→2→3→4→5→6, if K=3, then you must output 3→2→1→6→5→4; if K=4, you must output 4→3→2→1→5→6.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N ( ≤ 10 ​ 5 ) N (≤10​^5 ) N(105) which is the total number of nodes, and a positive K ( ≤ N ) K (≤N) K(N) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and N U L L NULL NULL is represented by − 1 -1 1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is an integer, and Next is the position of the next node.

Output Specification:

For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218

Sample Output:

00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1

题目大意:

反转单链表,给定常数K和单链表L,要求按每K个节点反转单链表,如:L: 1->2->3->4->5->6 K=3,输出:3->2->1->6->5->4,如果K=4,输出:4->3->2->1->5->6.

输入说明:

每次输入一个案例,对每个案例,第一行内容是链表第一个节点的地址,节点数N(N<=100,000)(不一定是最终形成的单链表的节点数),常数K(<=N),K是需要反转的子链表的长度,节点的地址是一个5位的非负整数,NULL用-1来代替。
下面输入N行 格式如下:
Address Data Next
Address代表节点的位置,Data是整型数字,Next是下一个节点的位置。

输出说明:

输出反转后的单链表,每个节点占一行,格式和输入的一样。

#include<iostream>
#include<stdio.h>
#include<algorithm>

using namespace std;

#define MAXSIZE 1000010

struct node		//使用顺序表存储data和下一个地址next
{
	int data;
	int next;
}node[MAXSIZE];

int List[MAXSIZE];
int main()
{
	int first, n, K; //输入头地址 和 n,k;
	int Address, Data, Next;

	cin >> first >> n >> K;
	for (int i=0; i < n; i++)
	{
		cin >> Address >> Data >> Next;
		node[Address].data = Data;
		node[Address].next = Next;
	}
	
	int j = 0;  //j用来存储能够首尾相连的节点数
	int p = first;   //p指示当前结点
	while (p != -1)	//保存所有节点的地址,便于后边翻转
	{
		List[j++] = p;
		p = node[p].next;
	}
	int i = 0;
	while (i + K <= j)
	{
		reverse(&List[i],&List[i+K]);
		i=i+K;
	}
	for (i = 0; i < j - 1; i++)
	{
		printf("%05d %d %05d\n",List[i],node[List[i]].data,List[i+1]);
	}
	printf("%05d %d -1\n",List[i],node[List[i]].data);
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值