杭电1088( Write a simple HTML Browser )

Write a simple HTML Browser

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10605    Accepted Submission(s): 3072


Problem Description
If you ever tried to read a html document on a Macintosh, you know how hard it is if no Netscape is installed.
Now, who can forget to install a HTML browser? This is very easy because most of the times you don't need one on a MAC because there is a Acrobate Reader which is native to MAC. But if you ever need one, what do you do?
Your task is to write a small html-browser. It should only display the content of the input-file and knows only the html commands (tags) <br> which is a linebreak and <hr> which is a horizontal ruler. Then you should treat all tabulators, spaces and newlines as one space and display the resulting text with no more than 80 characters on a line.
 

Input
The input consists of a text you should display. This text consists of words and HTML tags separated by one or more spaces, tabulators or newlines.
A word is a sequence of letters, numbers and punctuation. For example, "abc,123" is one word, but "abc, 123" are two words, namely "abc," and "123". A word is always shorter than 81 characters and does not contain any '<' or '>'. All HTML tags are either <br> or <hr>.
 

Output
You should display the the resulting text using this rules:
  . If you read a word in the input and the resulting line does not get longer than 80 chars, print it, else print it on a new line.
  . If you read a <br> in the input, start a new line.
  . If you read a <hr> in the input, start a new line unless you already are at the beginning of a line, display 80 characters of '-' and start a new line (again).

The last line is ended by a newline character.
 

Sample Input
  
  
Hallo, dies ist eine ziemlich lange Zeile, die in Html aber nicht umgebrochen wird. <br> Zwei <br> <br> produzieren zwei Newlines. Es gibt auch noch das tag <hr> was einen Trenner darstellt. Zwei <hr> <hr> produzieren zwei Horizontal Rulers. Achtung mehrere Leerzeichen irritieren Html genauso wenig wie mehrere Leerzeilen.
 

Sample Output
  
  
Hallo, dies ist eine ziemlich lange Zeile, die in Html aber nicht umgebrochen wird. Zwei produzieren zwei Newlines. Es gibt auch noch das tag -------------------------------------------------------------------------------- was einen Trenner darstellt. Zwei -------------------------------------------------------------------------------- -------------------------------------------------------------------------------- produzieren zwei Horizontal Rulers. Achtung mehrere Leerzeichen irritieren Html genauso wenig wie mehrere Leerzeilen.
这个题目是一个谨慎的细节题,一开始没看懂题意,后来看了别人对题目的理解,就懂题目的意思了。
题意:
a.每一行的加上读进的单词超过80个字符就换行,注:每个输出的单词间都有空格。
b.出现<br>就换一行;
c.出现<hr>,如果这行的字符数为0,就输出80个'-';否则换行输出80个'-'。
做个题我用了stringstream来做,因为stringstream能把字符串分割成n个子字符串,不管输入的字符串中间有多少空格或换行,它都能把分割。
下面是我的代码:
#include <iostream>
#include <sstream>
#include <string>
using namespace std;
int main()
{
	string sen;
	int len=0;
	while(getline(cin,sen))
	{
		stringstream str(sen);
		string word;
		while(str>>word)
		{
			if(word=="<br>")
			{
				len=0;
				cout<<endl;
				continue;
			}
			if(word=="<hr>")
			{
				if(len==0)
					cout<<"--------------------------------------------------------------------------------"<<endl;
				else
					cout<<endl<<"--------------------------------------------------------------------------------"<<endl;
			      len=0;
				  continue;
			}
			if(len==0)
			{
				len=word.size();
				cout<<word;
				continue;
			}
			if(len+word.size()+1>80)
			{
				len=word.size();
				cout<<endl<<word;
				continue;
			}
			len+=(word.size()+1);
			cout<<" "<<word;
		}
	}
	cout<<endl;
   return 0;
}
	


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值