HDU-1088-Write a simple HTML Browser

Write a simple HTML Browser

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10114 Accepted Submission(s): 2882

Problem Description
If you ever tried to read a html document on a Macintosh, you know how hard it is if no Netscape is installed.
Now, who can forget to install a HTML browser? This is very easy because most of the times you don’t need one on a MAC because there is a Acrobate Reader which is native to MAC. But if you ever need one, what do you do?
Your task is to write a small html-browser. It should only display the content of the input-file and knows only the html commands (tags)
which is a linebreak and


which is a horizontal ruler. Then you should treat all tabulators, spaces and newlines as one space and display the resulting text with no more than 80 characters on a line.

Input
The input consists of a text you should display. This text consists of words and HTML tags separated by one or more spaces, tabulators or newlines.
A word is a sequence of letters, numbers and punctuation. For example, “abc,123” is one word, but “abc, 123” are two words, namely “abc,” and “123”. A word is always shorter than 81 characters and does not contain any ‘<’ or ‘>’. All HTML tags are either
or


.

Output
You should display the the resulting text using this rules:
. If you read a word in the input and the resulting line does not get longer than 80 chars, print it, else print it on a new line.
. If you read a <br> in the input, start a new line.
. If you read a <hr> in the input, start a new line unless you already are at the beginning of a line, display 80 characters of ‘-’ and start a new line (again).
The last line is ended by a newline character.

Sample Input
Hallo, dies ist eine
ziemlich lange Zeile, die in Html
aber nicht umgebrochen wird.
<br>
Zwei <br> <br> produzieren zwei Newlines.
Es gibt auch noch das tag <hr> was einen Trenner darstellt.
Zwei <hr> <hr> produzieren zwei Horizontal Rulers.
Achtung mehrere Leerzeichen irritieren

Html genauso wenig wie

mehrere Leerzeilen.

Sample Output
Hallo, dies ist eine ziemlich lange Zeile, die in Html aber nicht umgebrochen
wird.
Zwei

produzieren zwei Newlines. Es gibt auch noch das tag

was einen Trenner darstellt. Zwei


produzieren zwei Horizontal Rulers. Achtung mehrere Leerzeichen irritieren Html
genauso wenig wie mehrere Leerzeilen.

题意:给出一段字符,按照规则输出即可。遇到<br>另起一行输出,遇到<hr>,另起一行输出80个-,一行最多输出80个字符,输出一个完整单词时需要考虑加上这个单词,这一行的字符是否超过80,如果超过80,这个单词只能另起一行输出,每两个单词之间有一个空格。

已无力吐槽此题有多坑,如果不是为了练习string,绝逼不会去死磕它
string用法http://blog.csdn.net/qq_32680617/article/details/51122395
代码

#include<stdio.h>
#include<string.h>
#include<string>
#include<algorithm>
#include<iostream>
#include<math.h>
#include<stack>
using namespace std;
int main()
{
    string s1;//接收数据
    string s2;//接收处理过的字符串
    int num=0;//每行字符数量
    while(cin>>s1)
    {
        if(s1=="<br>")//遇到就换一行
        {
            s2+='\n';
            num=0;//清空一行的字符数量
            continue;
        }
        else if(s1=="<hr>")//打印八十个字符
        {
            if(num!=0)
                s2+='\n';
            for(int i=0; i<80; i++)
                s2+='-';
            s2+='\n';
            num=0;//清空一行的字符数量
            continue;
        }
        if(num+1+s1.length()>80)//换行的第一个单词
        {
            s2+='\n';
            s2+=s1;
            num=s1.length();
        }
        else//不换行的单词
        {
            if(num!=0)
                s2+=' ';
            s2+=s1;
            num+=s1.length()+1;
        }
    }
    cout<<s2<<endl;//末尾的换行
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值