POJ1163 The Triangle【DFS】

题目:

Description

7
3   8
8   1   0
2   7   4   4
4   5   2   6   5
(Figure 1)
Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right. 

Input

Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.

Output

Your program is to write to standard output. The highest sum is written as an integer.

Sample Input

5
7
3 8
8 1 0 
2 7 4 4
4 5 2 6 5

Sample Output

30
思路:

很容易想到用递归遍历每种解法,找到最大值。这种思路的好处是从上往下推,考虑比较正面。往往我们为了不超时间会开辟一个数组来存储我们已经计算得到的结果。也就是平常说的以空间换时间。

#include <iostream>
using namespace std;
int nums[101][101]={0};
int lens[101][101]={0};
int num;
int dfs(int x,int y){//计算(x,y)点往下的最大长度,包含(x,y)点
	if(lens[x][y]>0)
		return lens[x][y];
	if(x==num){
		return nums[x][y];
	}
	int left=dfs(x+1,y);
	int right=dfs(x+1,y+1);
	int max=left>right?left:right;
	lens[x][y]=max+nums[x][y];
	return lens[x][y];
}
int main(){
	cin>>num;
	for(int i=1;i<=num;i++){  //我这里从1开始,index就代表是第几行啦,不用-1了~
		for(int j=1;j<=i;j++){//第几行,就有几个数
			cin>>nums[i][j];
		}
	}
	cout<<dfs(1,1);
	return 0;
}
我做完之后,去找寻别人的解法。发现有人是“从下往上”做的,具体思路如下:

从下往上推,具体来说就是假设轮到第i层的数字挑选他会从两个数字中和目前累计和最大的。
看上面这个例子,总共5层,
从第4层看。2会挑选5得到累加和7;7会挑选5得到累加和12;4会挑选6得到累加和10;下一个4会挑选6也得到10;
再看第3层。8会挑选累加和较大的7,他的累加和是12,以此类推·······直到最后比较3和8的累加和谁大,7和其相加。

代码:

#include <iostream>
using namespace std;

#define MAX(a, b) a>b?a:b
const int rMax = 101;
int dp[rMax][rMax];

int main()
{
   int row, i, j;
  
   scanf("%d", &row);
   for(i = 1; i <= row; i++)
	   for(j = 0; j < i; j++)
	       scanf("%d", &dp[i][j]);

   for(i = row-1; i >= 1; i--)
	   for(j = 0; j < i; j++)
		   dp[i][j] += MAX(dp[i+1][j], dp[i+1][j+1]);
   printf("%d\n", dp[1][0]);
   return 0;
}
感觉真是好简洁啊,有木有~

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值