111 - History GradingTime limit: 3.000 seconds |
History Grading
History Grading |
Background
Many problems in Computer Science involve maximizing some measure according to constraints.
Consider a history exam in which students are asked to put several historical events into chronological order. Students who order all the events correctly will receive full credit, but how should partial credit be awarded to students who incorrectly rank one or more of the historical events?
Some possibilities for partial credit include:
- 1 point for each event whose rank matches its correct rank
- 1 point for each event in the longest (not necessarily contiguous) sequence of events which are in the correct order relative to each other.
For example, if four events are correctly ordered 1 2 3 4 then the order 1 3 2 4 would receive a score of 2 using the first method (events 1 and 4 are correctly ranked) and a score of 3 using the second method (event sequences 1 2 4 and 1 3 4 are both in the correct order relative to each other).
In this problem you are asked to write a program to score such questions using the second method.
The Problem
Given the correct chronological order of n events as where denotes the ranking of event i in the correct chronological order and a sequence of student responses where denotes the chronological rank given by the student to event i; determine the length of the longest (not necessarily contiguous) sequence of events in the student responses that are in the correct chronological order relative to each other.
The Input
The first line of the input will consist of one integer n indicating the number of events with . The second line will contain n integers, indicating the correct chronological order of n events. The remaining lines will each consist of n integers with each line representing a student's chronological ordering of the n events. All lines will contain n numbers in the range , with each number appearing exactly once per line, and with each number separated from other numbers on the same line by one or more spaces.
The Output
For each student ranking of events your program should print the score for that ranking. There should be one line of output for each student ranking.
Sample Input 1
4 4 2 3 1 1 3 2 4 3 2 1 4 2 3 4 1
Sample Output 1
1 2 3
Sample Input 2
10 3 1 2 4 9 5 10 6 8 7 1 2 3 4 5 6 7 8 9 10 4 7 2 3 10 6 9 1 5 8 3 1 2 4 9 5 10 6 8 7 2 10 1 3 8 4 9 5 7 6
Sample Output 2
6 5 10 9
题目大意:
输入n,代表n个事件。然后输入n个正整数ci,代表第i个事件发生的年份为第ci年。接下来输入多组学生的回答,每组n个正整数ri,同样代表第i个事件发生的年味为第ri年。得分规则为:学生的回答与答案中事件按时间先后排序的序列的相对位置相同时(不需连续),每个事件加1分。求每个学生能得多少分。
解题思路:
关键要读懂题意,将输入数据转换为按时间先后排序的事件序列,然后用LCS(最长公共子序列)求解即可。
状态转移方程:dp(i)(j) = max{ dp(i-1)(j), dp(i)(j-1) | A[i]!=B[j] }
dp(i)(j) = max{ dp(i-1)(j), dp(i)(j-1), dp(i-1)(j-1)+1 | A[i]=B[j] }
#include <cstdio>
#include <cstring>
#define max(a,b) (a>b?a:b)
void LCS(int A[], int B[], int len, int dp[25][25]){
for(int i=1;i<=len;++i){
for(int j=1;j<=len;++j){
dp[i][j]=max( dp[i-1][j], dp[i][j-1] );
if(A[i]==B[j]) dp[i][j]=max( dp[i][j], dp[i-1][j-1]+1 );
}
}
//printf("dp[][]=%d\n",dp[len][len]);
}
int main()
{
//freopen("in.txt","r",stdin);
int n; int A[25]; int B[25];
scanf("%d",&n);
for(int i=1,a;i<=n;++i) scanf("%d",&a),A[a]=i;
while(~scanf("%d",&B[1])){
B[B[1]]=1;
for(int i=2,b;i<=n;++i) scanf("%d",&b),B[b]=i;
int dp[25][25]={0};
LCS(A, B, n, dp);
printf("%d\n",dp[n][n]);
}
return 0;
}
History Grading
History Grading |
Background
Many problems in Computer Science involve maximizing some measure according to constraints.
Consider a history exam in which students are asked to put several historical events into chronological order. Students who order all the events correctly will receive full credit, but how should partial credit be awarded to students who incorrectly rank one or more of the historical events?
Some possibilities for partial credit include:
- 1 point for each event whose rank matches its correct rank
- 1 point for each event in the longest (not necessarily contiguous) sequence of events which are in the correct order relative to each other.
For example, if four events are correctly ordered 1 2 3 4 then the order 1 3 2 4 would receive a score of 2 using the first method (events 1 and 4 are correctly ranked) and a score of 3 using the second method (event sequences 1 2 4 and 1 3 4 are both in the correct order relative to each other).
In this problem you are asked to write a program to score such questions using the second method.
The Problem
Given the correct chronological order of n events as where denotes the ranking of event i in the correct chronological order and a sequence of student responses where denotes the chronological rank given by the student to event i; determine the length of the longest (not necessarily contiguous) sequence of events in the student responses that are in the correct chronological order relative to each other.
The Input
The first line of the input will consist of one integer n indicating the number of events with . The second line will contain n integers, indicating the correct chronological order of n events. The remaining lines will each consist of n integers with each line representing a student's chronological ordering of the n events. All lines will contain n numbers in the range , with each number appearing exactly once per line, and with each number separated from other numbers on the same line by one or more spaces.
The Output
For each student ranking of events your program should print the score for that ranking. There should be one line of output for each student ranking.
Sample Input 1
4 4 2 3 1 1 3 2 4 3 2 1 4 2 3 4 1
Sample Output 1
1 2 3
Sample Input 2
10 3 1 2 4 9 5 10 6 8 7 1 2 3 4 5 6 7 8 9 10 4 7 2 3 10 6 9 1 5 8 3 1 2 4 9 5 10 6 8 7 2 10 1 3 8 4 9 5 7 6
Sample Output 2
6 5 10 9