【解题报告】uva103_Stacking Boxes(堆砌盒子, dp)

16 篇文章 0 订阅
12 篇文章 0 订阅

103 - Stacking Boxes

Time limit: 3.000 seconds



 Stacking Boxes 

Background

Some concepts in Mathematics and Computer Science are simple in one or two dimensions but become more complex when extended to arbitrary dimensions. Consider solving differential equations in several dimensions and analyzing the topology of an n-dimensional hypercube. The former is much more complicated than its one dimensional relative while the latter bears a remarkable resemblance to its ``lower-class'' cousin.

The Problem

Consider an n-dimensional ``box'' given by its dimensions. In two dimensions the box (2,3) might represent a box with length 2 units and width 3 units. In three dimensions the box (4,8,9) can represent a box tex2html_wrap_inline40(length, width, and height). In 6 dimensions it is, perhaps, unclear what the box (4,5,6,7,8,9) represents; but we can analyze properties of the box such as the sum of its dimensions.

In this problem you will analyze a property of a group of n-dimensional boxes. You are to determine the longest nesting string of boxes, that is a sequence of boxes tex2html_wrap_inline44 such that each box tex2html_wrap_inline46 nests in boxtex2html_wrap_inline48 ( tex2html_wrap_inline50 .

A box D = ( tex2html_wrap_inline52 ) nests in a box E = ( tex2html_wrap_inline54 ) if there is some rearrangement of the tex2html_wrap_inline56 such that when rearranged each dimension is less than the corresponding dimension in box E. This loosely corresponds to turning box D to see if it will fit in box E. However, since any rearrangement suffices, box D can be contorted, not just turned (see examples below).

For example, the box D = (2,6) nests in the box E = (7,3) since D can be rearranged as (6,2) so that each dimension is less than the corresponding dimension in E. The box D = (9,5,7,3) does NOT nest in the box E = (2,10,6,8) since no rearrangement of D results in a box that satisfies the nesting property, but F = (9,5,7,1) does nest in box E since F can be rearranged as (1,9,5,7) which nests in E.

Formally, we define nesting as follows: box D = ( tex2html_wrap_inline52 ) nests in box E = ( tex2html_wrap_inline54 ) if there is a permutation tex2html_wrap_inline62 of tex2html_wrap_inline64 such that ( tex2html_wrap_inline66 ) ``fits'' in ( tex2html_wrap_inline54 ) i.e., if tex2html_wrap_inline70for all tex2html_wrap_inline72 .

The Input

The input consists of a series of box sequences. Each box sequence begins with a line consisting of the the number of boxes k in the sequence followed by the dimensionality of the boxes, n (on the same line.)

This line is followed by k lines, one line per box with the n measurements of each box on one line separated by one or more spaces. The tex2html_wrap_inline82 line in the sequence ( tex2html_wrap_inline84 ) gives the measurements for the tex2html_wrap_inline82 box.

There may be several box sequences in the input file. Your program should process all of them and determine, for each sequence, which of the k boxes determine the longest nesting string and the length of that nesting string (the number of boxes in the string).

In this problem the maximum dimensionality is 10 and the minimum dimensionality is 1. The maximum number of boxes in a sequence is 30.

The Output

For each box sequence in the input file, output the length of the longest nesting string on one line followed on the next line by a list of the boxes that comprise this string in order. The ``smallest'' or ``innermost'' box of the nesting string should be listed first, the next box (if there is one) should be listed second, etc.

The boxes should be numbered according to the order in which they appeared in the input file (first box is box 1, etc.).

If there is more than one longest nesting string then any one of them can be output.

Sample Input

5 2
3 7
8 10
5 2
9 11
21 18
8 6
5 2 20 1 30 10
23 15 7 9 11 3
40 50 34 24 14 4
9 10 11 12 13 14
31 4 18 8 27 17
44 32 13 19 41 19
1 2 3 4 5 6
80 37 47 18 21 9

Sample Output

5
3 1 2 4 5
4
7 2 5 6

题目大意:

首先输入k和n,k代表有k个盒子,n代表盒子的维度。

求这些盒子最长的嵌套序列,并按照由内而外的顺序将盒子的编号打印出来(编号按照输入顺序确定)。

盒子嵌套规则如下:

box D = ( tex2html_wrap_inline52 ) nests in box E = ( tex2html_wrap_inline54 ) if there is a permutation tex2html_wrap_inline62 of tex2html_wrap_inline64 such that ( tex2html_wrap_inline66 ) ``fits'' in ( tex2html_wrap_inline54 ) i.e., if tex2html_wrap_inline70for all tex2html_wrap_inline72 .


解题思路:

定义状态dp(i)(j),代表前i个盒子中以j作为最外层盒子的最长序列。

对输入数据进行排序处理,确保第i个盒子不能被前i-1个盒子装入。

状态转移方程:dp(i)(i) = { dp(i-1)(j)+1 | j<i, box[j]<box[i] }

              dp(i)(j) = { dp(i-1)(j) | j<i }



#include <cstdio>
#include <algorithm>
#define max(a,b) (a>b?a:b)

using std::sort;

int k,n;

struct _box{
    int num;
    int v[11];
    bool operator<(const _box &A)const {
        for(int i=1;i<=n;++i) {
            if(v[i]>=A.v[i]) return false;
        }
        return true;
    }
}box[31];

bool comp(const _box &A,const _box &B){
    return A.v[1]<B.v[1];
}

int main()
{
    //freopen("in.txt","r",stdin);

    while(~scanf("%d%d",&k,&n)){
        for(int i=1;i<=k;++i){
            box[i].num=i;
            for(int j=1;j<=n;++j) scanf("%d",&box[i].v[j]);
            sort(box[i].v+1,box[i].v+1+n);
        }
        sort(box+1,box+1+k,comp);

        /*for(int i=1;i<=k;++i){
            for(int j=1;j<=n;++j) printf("%d ",box[i].v[j]);
            printf("\n");
        }*/

        int dp[30][30]={0};//dp[i]的值代表最外层盒子为i的最长序列的长度
        int res[30][30]={0};//记录盒子嵌套结果

        for(int i=1;i<=k;++i){//初始化:至少为1
            for(int j=1;j<=i;++j) dp[i][j]=1;
        }

        for(int i=2;i<=k;++i){//枚举盒子i
            for(int j=1;j<i;++j){//将i放入前面所构成的最长序列中
                dp[i][j]=dp[i-1][j];
                if(box[j]<box[i]){//box[i]可作为最外层
                    if(dp[i-1][j]+1>dp[i][i]){
                        dp[i][i]=dp[i-1][j]+1;
                        res[i][i]=j;
                    }
                }
            }
            //for(int j=1;j<=i;++j) printf("dp[%d][%d]=%d ",i,j,dp[i][j]);printf("\n");
        }
        //printf("\n"); for(int i=1;i<=k;++i) printf("%d ",dp[k][i]); printf("\n");

        int max_v=0,max_i;//最大值和其角标
        for(int i=1;i<=k;++i){
            if(dp[k][i]>max_v) max_v=dp[k][i],max_i=i;
        }

        int ar[30],i_r=0,t=max_i;
        while(i_r<max_v-1){
            ar[i_r++]=res[t][t];
            t=res[t][t];
        }

        printf("%d\n",max_v);
        for(int i=i_r-1;i>=0;--i) printf("%d ",box[ar[i]].num);
        printf("%d\n",box[max_i].num);
    }
    return 0;
}

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值