sicily 1028. Hanoi Tower Sequence

1028. Hanoi Tower Sequence

Constraints

Time Limit: 1 secs, Memory Limit: 32 MB

Description

Hanoi Tower is a famous game invented by the French mathematician Edourard Lucas in 1883. We are given a tower of n disks, initially stacked in decreasing size on one of three pegs. The objective is to transfer the entire tower to one of the other pegs, moving only one disk at a time and never moving a larger one onto a smaller. 

The best way to tackle this problem is well known: We first transfer the n-1 smallest to a different peg (by recursion), then move the largest, and finally transfer the n-1 smallest back onto the largest. For example, Fig 1 shows the steps of moving 3 disks from peg 1 to peg 3.

Now we can get a sequence which consists of the red numbers of Fig 1: 1, 2, 1, 3, 1, 2, 1. The ith element of the sequence means the label of the disk that is moved in the ith step. When n = 4, we get a longer sequence: 1, 2, 1, 3, 1, 2, 1, 4, 1, 2, 1, 3, 1, 2, 1. Obviously, the larger n is, the longer this sequence will be.
Given an integer p, your task is to find out the pth element of this sequence.

Input

The first line of the input file is T, the number of test cases.
Each test case contains one integer p (1<=p<10^100).

Output

Output the pth element of the sequence in a single line. See the sample for the output format.
Print a blank line between the test cases.

Sample Input

4
1
4
100
100000000000000

Sample Output

Case 1: 1
 
Case 2: 3
 
Case 3: 3
 
Case 4: 15

题目分析

大整数除法

计算给定的大整数能整除2的次数加1


#include <iostream>
#include <string.h>

int a[101];
int len;

int find(int start) {
  if (a[len - 1] % 2 == 1)
    return 0;
    
  for (int d = start; d < len - 1; ++d) {
    a[d + 1] += (a[d] % 2) * 10;
    a[d] /= 2;    
  }
  a[len - 1] /= 2;
  
  if (a[start] == 0)
    start++;
  return 1 + find(start);  
}

int main()
{
  int test;
  std::cin >> test;
  std::string key; 
   
  for (int c = 1; c <= test; ++c) {
    if (c != 1)
      std::cout << std::endl;  

    std::cin >> key;
    memset(a, 0, sizeof(a));
    for (int d = 0; key[d] != '\0'; ++d)
      a[d] = key[d] - '0';
    len = key.length();
    
    std::cout << "Case " << c << ": " << 1 + find(0) << std::endl;    
  }  
  return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值