HDU 1020 Encoding

怎么说呢,发现自己被坑了好几次,因为我没看清楚数据的范围  搞的我数组开小了 贡献了几次WA

我还以为是我理解错题意了,改了多次代码,最后还是第一次的代码,数组开到10005  瞬间AC 有没有 我是不是很笨呢

下面是题目:(不得不说,这是一道很水的题目)

Encoding

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 26250    Accepted Submission(s): 11565


Problem Description
Given a string containing only 'A' - 'Z', we could encode it using the following method: 

1. Each sub-string containing k same characters should be encoded to "kX" where "X" is the only character in this sub-string.

2. If the length of the sub-string is 1, '1' should be ignored.
 

Input
The first line contains an integer N (1 <= N <= 100) which indicates the number of test cases. The next N lines contain N strings. Each string consists of only 'A' - 'Z' and the length is less than 10000.
 

Output
For each test case, output the encoded string in a line.
 

Sample Input
  
  
2 ABC ABBCCC
 

Sample Output
  
  
ABC A2B3C
下面是我的AC代码:

#include<stdio.h>
int n;
int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        getchar();
        while(n--)
        {
            char a[10005];
            scanf("%s",a);
            int sum=0;
            for(int i=0;a[i]!='\0';i++)
            {
                if(a[i]==a[i+1])
                    sum++;
                else
                    if(sum==0)
                    {
                        printf("%c",a[i]);
                        sum=0;
                    }
                    else
                    {
                        printf("%d%c",sum+1,a[i]);
                        sum=0;
                    }
            }
            printf("\n");
        }
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值