nyoj1242 Interference Signal

Interference Signal

时间限制:2000 ms  |  内存限制:65535 KB
难度:1
描述

Dr.Kong’s laboratory monitorsome interference signals. The interference signals can be digitized into aseries of positive integer. May be, there are N integers a1,a2,…,an.

 

Dr.Kong wants toknow the averagestrength of a contiguous interference signal block. the block mustcontain at least M integers.

 

Pleasehelp Dr.Kong tocalculate the maximumaverage strength, giventhe constraint.

输入
The input contains K test cases. Each test case specifies:
* Line 1: Two space-separated integers, N and M.
* Lines2~line N+1: ai (i=1,2,…,N)
1 ≤ K≤ 8, 5 ≤ N≤ 2000, 1 ≤ M ≤ N, 0 ≤ ai ≤9999
输出
For each test case generate a single line containing a single integer that is 1000 times the maximal average value. Do not perform rounding.
样例输入
2 
10 6
6 
4
2
10
3
8
5
9
4
1
5 2
10
3
8
5 
9
样例输出
6500
7333
 #include <stdio.h>
 #define Max_N 2001
 int s[Max_N];
 int Max(double a,double b)
 {
 	return a>b?a:b;
 }
 int main()
 {
 	int T;
 	scanf("%d",&T);
 	while(T--)
 	{
 		int m,n,g;
 		scanf("%d%d",&n,&m);
 		int i,j;
 		s[0] = 0;
 		for(i=1;i<=n;i++)
 		{
 			scanf("%d",&g);
 			s[i] = s[i-1] + g; 
 		}
 		double sum = -0x3f3f3f3f,max;
 		for(i=0;i<n;i++)
 		{
 			for(j=i+m;j<=n;j++)
 			{
 				max = (s[j]-s[i])*1.0/(j-i)*1000;
 				sum = Max(max,sum);
 			}
 		}
 		printf("%d\n",(int)sum);
 	}
 	return 0;
 }   



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值