NYOJ 1242Interference Signal



Interference Signal

时间限制: 2000 ms  |  内存限制: 65535 KB
难度: 1
描述

Dr.Kong’s laboratory monitor some interference signals. The interference signals can be digitized into a series of positive integer. May be, there are N integers a1,a2,…,an.

 

Dr.Kong wants to know the average strength of a contiguous interference signal block. the block must contain at least M integers.

 

Please help Dr.Kong to calculate the maximum average strength, given the constraint.

输入
The input contains K test cases. Each test case specifies:
* Line 1: Two space-separated integers, N and M.
* Lines2~line N+1: ai (i=1,2,…,N)
1 ≤ K≤ 8, 5 ≤ N≤ 2000, 1 ≤ M ≤ N, 0 ≤ ai ≤9999
输出
For each test case generate a single line containing a single integer that is 1000 times the maximal average value. Do not perform rounding.
样例输入
2 10 66 42103859415 210385 9 
样例输出
65007333
来源
第八届河南省程序设计大赛

题目大意就是 输入N个数 然后从找出大于或等于M个连续的数的相加的最大平均值  。。。 其实题目比较水

输出的时候有坑,浪费了半个多小时。。。 输出不能用printf("%.lf\n", max*1000);  要用%d输出

#include<stdio.h>
int main() {
  int k, n, m, a[2005], count, con;
  scanf("%d", &k);
  while(k--) {
    double ave, max = -1.0;
    scanf("%d%d", &n, &m);
    for(int i = 0; i < n; i++)
      scanf("%d", &a[i]);
    count = m;
    for(int t = 0; t <= n-m; t++) {
      for(int i = 0; i <= n-m && i+count <= n; i++) {
        double sum = 0.0;
        for(int j = i; j < count+i; j++) {
          sum += a[j];
          //printf("%d ", a[j]);
        }
        ave = sum/count;
        if(ave > max) max = ave;
        //printf(" sum = %lf count = %d 平均值是:%lf\n", sum, count, ave);
      }
      count++;//控制求平均值数的个数 
    }
    printf("%d\n", (int)(max*1000));
  }
} 

这种题还是自己做比较好  循环控制条件不自己去试不容易看懂


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值