POJ_3053_ Fence Repair

/*
 Fence Repair
Time Limit: 2000MS        Memory Limit: 65536K
Total Submissions: 46301        Accepted: 15086

Description

Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made; you should ignore it, too.

FJ sadly realizes that he doesn't own a saw with which to cut the wood, so he mosies over to Farmer Don's Farm with this long board and politely asks if he may borrow a saw.

Farmer Don, a closet capitalist, doesn't lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.

Input
Line 1: One integer N, the number of planks
Lines 2..N+1: Each line contains a single integer describing the length of a needed plank

Output
Line 1: One integer: the minimum amount of money he must spend to make N-1 cuts

Sample Input

3
8
5
8

Sample Output

34
 
题意:农夫约翰为了修理栅栏,要将一块很长的木板切割为N块。准备切成的木板的长度为L1,L2,..Ln.未切割木板的长度恰好为切割后木板长度的总和。每次切断木板时,需要的
开销为这块木板的长度。例如长度为21的木板要切成长度为 5,8,8,的三块木板。长度为21的木板切成长为13和8的板时,开销为21.再将长度为13的板切成长度为5 和 8的 板时
,开销是13.于是合计开销是34.请求出按照目标要求将木板切割完最小的开销是多少。
 
 
 解题思路:

利用Huffman思想,要使总费用最小,那么每次只选取最小长度的两块木板相加,再把这些和,累加到总费用中即可

利用优先队列:
 
HuffmanTree思想是:

(1)先把输入的所有元素升序排序,再选取最小的两个元素,把他们的和值累加到总费用

(2)把这两个最小元素出队,他们的和值入队,重新排列所有元素,重复(1),直至队列中元素个数<=1,则累计的费用就是最小费用

*/

#include <cstdio>
#include <cstring>
#include <queue>
using namespace std;
typedef long long ll;
int n;
int main()
{
	while(scanf("%d",&n)!=EOF)
	{
		int m,i;
		priority_queue<int,vector<int>,greater<int> >Q;
		for(i=0;i<n;i++)
		{
			scanf("%d",&m);
			Q.push(m);
		}
		ll sum = 0,a,b,c;
		if(Q.size()==1) //剩最后一个元素了 
		{
			a = Q.top();
			Q.pop();
			sum += a; 
		}
		while(Q.size()>1) //每次找最小的两个出队列,然后相加,值在入队列 
		{
			a = Q.top();
			Q.pop();
			b = Q.top();
			Q.pop();
			c = a + b;	
			sum += c;
			Q.push(c); 
		}
		printf("%lld\n",sum);	
	}
	return 0;
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值