删除链表中的素数

函数deletesushu删除head指向的链表中data值为素数的结点并返回删除结点后的新链表。例如链表8->7->5->3->2->9->6->4->1->0删除data值为素数得到的链表为:8->9->6->4->1>0。
说明:素数必须大于等于2。
(样例输入第一行为链表节点个数,第二行为从右至左的链表,样例输出为从左至右的链表)
样例输入:
5
5 4 3 2 1
样例输出:
4 1

#include<iostream>
#include<math.h>
using namespace std;
bool sushu(int n);
struct ListNode
{
 int data;
 ListNode *next;
};
ListNode *deletesushu(ListNode *head)
{
 ListNode *p , *t;
 int d;
 while(sushu(head->data))
 {
  head=head->next;
 }
 p=head;
 while(p->next)
 {
  d=p->next->data;
  if(sushu(d))
  {
   t=p->next;
   p->next=p->next->next;
   delete t;
   continue;
  }
  p=p->next;
 }
 return head;
}
int main()
{
 struct ListNode *head=NULL,*t1,*t2,*t;
 int n;
 cin>>n;
 head = new ListNode;
 cin>>head->data;
 t2=head;
 for(int i=0;i<n-1;i++)
 {
  t1=new ListNode;
  cin>>t1->data;
  t2->next=t1;
  t2=t1;
 }
 t2->next=NULL;
 head=deletesushu(head);
 t=head;
 while(t)
 {
  cout<<t->data<<" ";
  t=t->next;
 }
 cout<<endl;
 return 0;
}
bool sushu(int n)
{
 if(n<2) 
 {
  return 0;
 }
 if(n==2)
 {
  return 1;
 }
 for(int i=2;i<=sqrt(n);i++)
 {
  if(n%i==0)
  {
   return 0;
  }
 }
 return 1;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

【执珪】瑕瑜·夕环玦

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值