hdu 5776 sum(前缀和取模)

sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 323    Accepted Submission(s): 156


Problem Description
Given a sequence, you're asked whether there exists a consecutive subsequence whose sum is divisible by m. output YES, otherwise output NO
 

Input
The first line of the input has an integer T ( 1T10 ), which represents the number of test cases. 
For each test case, there are two lines:
1.The first line contains two positive integers n, m ( 1n100000 1m5000 ).
2.The second line contains n positive integers x ( 1x100 ) according to the sequence.
 

Output
Output T lines, each line print a YES or NO.
 

Sample Input
  
  
2 3 3 1 2 3 5 7 6 6 6 6 6
 

Sample Output
  
  
YES NO
 

Source

题意:有n个数,问存不存在连续子序列之和是m的倍数

思路:比赛的时候看错题意,以为是求等于m的,故用尺取法秒解,居然还AC了,真是费解 ...

现在重新做一遍,此题应该用前缀和来处理问题。

如果前缀和存在%m后==0的不用考虑,YES

如果存在余数为1~m-1的个数大于一个时我们也能保证为YES  为什么呢? 我们假设sum[1~i]%m为k,sum[1~j]%m为k(j>i)

那么容易想到sum[i+1,j]%m==0

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
#define N 100050
int a[N],sum[N];
int vis[N];
int main()
{
    int T,n,m,t;
    scanf("%d",&T);
    while(T--)
    {
        memset(vis,0,sizeof(vis));
        scanf("%d %d",&n,&m);
        sum[0]=0;
        for(int i=1;i<=n;i++)
                {
                    scanf("%d",&a[i]);
                    sum[i]=sum[i-1]+a[i];
                    vis[sum[i]%m]++;
                }
        int flag=0;
        if(vis[0]) flag=1;
        else
        {
            for(int i=1;i<m;i++)
                if(vis[i]>=2)
                flag=1;
        }
        if(flag) printf("YES\n");
        else printf("NO\n");
    }
    return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值