HDOJ-2058 The sum problem(等差数列求和)

The sum problem

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 20251    Accepted Submission(s): 5943


Problem Description
Given a sequence 1,2,3,......N, your job is to calculate all the possible sub-sequences that the sum of the sub-sequence is M.
 

Input
Input contains multiple test cases. each case contains two integers N, M( 1 <= N, M <= 1000000000).input ends with N = M = 0.
 

Output
For each test case, print all the possible sub-sequence that its sum is M.The format is show in the sample below.print a blank line after each test case.
 

Sample Input
  
  
20 10 50 30 0 0
 

Sample Output
  
  
[1,4] [10,10] [4,8] [6,9] [9,11] [30,30]
 
本题主要运用了等差数列的求和公式
等差数列  s=n*(a1+an)/2;
这里用i表示a1,先枚举连续的长度为j,进而求出i,然后判断是否求和为m。

#include<stdio.h>
#include<math.h>
int main()
{
    int t,n,m,i,j;//i为开始的点,j为此区间的长度
    while(~scanf("%d%d",&n,&m)&&(n||m))
    {
        t=(int)sqrt(2.0*m);
        for(j=t;j>=1;j--)//根据数列求和公式判断
        {
            int i;
            i=(2*m/j+(1-j))/2;
            if(j*(2*i+j-1)==2*m)
            {
                printf("[%d,%d]\n",i,i+j-1);
            }
        }
        printf("\n");
    }
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值