UVa-11300 - Spreading the Wealth(中位数)

11300 - Spreading the Wealth

 Problem

A Communist regime is trying to redistribute wealth in a village. They have have decided to sit everyone around a circular table. First, everyone has converted all of their properties to coins of equal value, such that the total number of coins is divisible by the number of people in the village. Finally, each person gives a number of coins to the person on his right and a number coins to the person on his left, such that in the end, everyone has the same number of coins. Given the number of coins of each person, compute the minimum number of coins that must be transferred using this method so that everyone has the same number of coins.
The Input

There is a number of inputs. Each input begins with n(n<1000001), the number of people in the village. nlines follow, giving the number of coins of each person in the village, in counterclockwise order around the table. The total number of coins will fit inside an unsigned 64 bit integer.
The Output

For each input, output the minimum number of coins that must be transferred on a single line.
Sample Input

3
100
100
100
4
1
2
5
4

Sample Output

0
4
/*
题意:n个人坐成一圈,每个人有一些钱,现在要平分这些钱,
每个人只能把钱给周围的人,问最少要转移多少钱才能使最终金币想等。
思路:
最终金币平均数为M
每个人初始的金币为Ai
设Xi是第i个人给第i-1个(1给第n个)的金币数
那么就有了n种状态,
A1-x1+x2 = M ->  x2 = M-A1+x1 = x1 - C1( C1 = A1 - M)
A2-x2+x3 = M->  x3 = M-A2+x2 = x1 - C2
……
Ak-xk+x(k+1) = M
这里因为是个环,我们考虑了1给n的,就不用再考虑n给n-1的了
所以也可以给n的,去掉1的
min(|x1|+|x1-C1|+|x1-C2|+...+|x1-Cn-1|)
所以x1为这些数C[i]的中位数时,达到min
中位数的证明(略)
那么C[i]该怎么求呢?
C[2] = x1 - x3   C[1] = x1 - x2
相减 C[2]  - C[1]=  x2- x3 = A2 - M(由红色公式部分导出)  C[2] C[1] +  A2 - M
递推得出 C[i]- C[i-1] +  Ai - M
这里一看想用最大值最小值方面来做,看了书才知道原来是道中位数的题目
也是感觉到奇妙啊,有种感觉和中间大小的值有关,但是由于时间,心太急了
没去想做复杂点的推导,对于刘汝佳找的题目,认真做会收获很大的,加油啊
*/

#include<iostream>
#include<cstdio>
#include<cmath>
#include<algorithm>
using namespace std;
const int N = 1000005;
int a[N],c[N];
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        long long sum = 0;
        for(int i = 1;i <= n;i++)
        {
            scanf("%d",&a[i]);
            sum += a[i];
        }
        int m = sum / n;//平均值
        c[0] = 0;
        for(int i = 1;i < n;i++)
            c[i] = c[i-1] + a[i] - m;
        sort(c,c+n);
        long long ans = 0;
        int x1 = c[n/2];//中位数
        for(int i = 0;i < n;i++)
            ans += abs(x1 - c[i]);
        printf("%lld\n",ans);
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值