POJ-1569 Myacm Triangles(计算几何)

Myacm Triangles
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 1049 Accepted: 590

Description


There has been considerable archeological work on the ancient Myacm culture. Many artifacts have been found in what have been called power fields: a fairly small area, less than 100 meters square where there are from four to fifteen tall monuments with crystals on top. Such an area is mapped out above. Most of the artifacts discovered have come from inside a triangular area between just three of the monuments, now called the power triangle. After considerable analysis archeologists agree how this triangle is selected from all the triangles with three monuments as vertices: it is the triangle with the largest possible area that does not contain any other monuments inside the triangle or on an edge of the triangle. Each field contains only one such triangle.  

Archeological teams are continuing to find more power fields. They would like to automate the task of locating the power triangles in power fields. Write a program that takes the positions of the monuments in any number of power fields as input and determines the power triangle for each power field.  

A useful formula: the area of a triangle with vertices (x1, y1), (x2, y2), and (x3, y3) is the absolute value of  

0.5 * [(y3 - y1)(x2 - x1) - (y2 - y1)(x3 - x1)].  

Input

For each power field there are several lines of data. The first line is the number of monuments: at least 4, and at most 15. For each monument there is a data line that starts with a one character label for the monument and is followed by the coordinates of the monument, which are nonnegative integers less than 100. The first label is A, and the next is B, and so on.  

There is at least one such power field described. The end of input is indicated by a 0 for the number of monuments. The first sample data below corresponds to the diagram in the problem.  

Output

For each power field there is one line of output. It contains the three labels of the vertices of the power triangle, listed in increasing alphabetical order, with no spaces.

Sample Input

6
A 1 0
B 4 0
C 0 3
D 1 3
E 4 4
F 0 6
4
A 0 0
B 1 0
C 99 0
D 99 99
0

Sample Output

BEF
BCD


从昨天开始遇到问题了,每个程序都会因为 一些特别小的bug,而一直卡题,昨天是因为个什么来着,弄的我心情特别差,今天竟然因为最简单循环的写错了而浪费那么多时间,感觉自己在深深地为这些时间的丢失感到肉痛,归根结底是自己不仔细,而且基础的水题没怎么刷,对细节方面没敏感了。

好吧,每天拿个水题练练手,不能把最基础的东西给丢了,而且细节真的真的好重要,而且马上就跟codeforces,不能缺少比赛,毕竟自己是准备竞赛的,正如看到的知乎上说的,acm是算法竞赛,不能因为算法的学习丢掉了最关键的竞赛。

/*
题目大意:平面上有一些点(很少),求以这些点为顶点
的三角形中,内部无其他点的面积最大的三角形是哪个
*/

思路:

1.用面积的方法判断,即如果一个点在三角形内(或圆上),那么这个点与三角形的任意边组成的三角形面积之和等于原三角形面积

2.枚举三角形三个顶点a,b,c,看(b-a)^(c-b)符号得出是顺时针序还是逆时针序,然后用叉积判断其他点是否在三角内(边为逆时针序的情况下,点同时在三条边的左边则为在三角形内。此法同样适用于判断点是否在凸多边形内)

第二个好复杂,虽然是老师讲的,我还是第一个把,毕竟人家公式都给了,不能不用啊

<span style="color:#66FF99;">/*</span>
题目大意:平面上有一些点(很少),求以这些点为顶点
的三角形中,内部无其他点的面积最大的三角形是哪个
*/
#include <iostream>
#include<cstdio>
#include <cmath>
#include <algorithm>
#include <cstring>
#include <string>
using namespace std;
struct Point
{
    double x,y;
    string name;
};
Point ps[25];

double Area(int i,int j,int k)
{
    return fabs((ps[k].y-ps[i].y)*(ps[j].x-ps[i].x)-(ps[j].y-ps[i].y)*(ps[k].x-ps[i].x));
}
int main()
{
    int n;
    while(~scanf("%d",&n)&&n)
    {
        int Msum = 0;
        int a,b,c;
        for(int i = 1;i <= n;i++)
        {
            cin >> ps[i].name;
            cin >>ps[i].x >> ps[i].y;
            //scanf("%lf%lf",&,&);
        }
            //printf("11\n");
        for(int i = 1;i <= n-2;i++)
            for(int j = i+1;j <= n-1;j++)
                for(int k = j+1;k <= n;k++)//
                {

                    //if(i==j || i==k || j==k)
                        //continue;
                    int flag=1;
                    int temp=Area(i,j,k);
                    for(int t=0;t<n;t++)
                    {
                        if(t!=i&&t!=j&&t!=k)
                        {
                            if(temp==(Area(t,i,j)+Area(t,j,k)+Area(t,k,i)))
                            {
                                flag=0;
                                break;
                            }
                        }
                    }
                    if(flag&&temp>Msum)
                    {

                            Msum=temp;
                            a=i;
                            b=j;
                            c=k;

                    }
                }
          cout<<ps[a].name<<ps[b].name<<ps[c].name<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值