UVA-1388 && POJ-3154 墓地雕塑(数学)

Graveyard
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 1544 Accepted: 799 Special Judge

Description

Programming contests became so popular in the year 2397 that the governor of New Earck — the largest human-inhabited planet of the galaxy — opened a special Alley of Contestant Memories (ACM) at the local graveyard. The ACM encircles a green park, and holds the holographic statues of famous contestants placed equidistantly along the park perimeter. The alley has to be renewed from time to time when a new group of memorials arrives.

When new memorials are added, the exact place for each can be selected arbitrarily along the ACM, but the equidistant disposition must be maintained by moving some of the old statues along the alley.

Surprisingly, humans are still quite superstitious in 24th century: the graveyard keepers believe the holograms are holding dead people souls, and thus always try to renew the ACM with minimal possible movements of existing statues (besides, the holographic equipment is very heavy). Statues are moved along the park perimeter. Your work is to find a renewal plan which minimizes the sum of travel distances of all statues. Installation of a new hologram adds no distance penalty, so choose the places for newcomers wisely!

Input

Input file contains two integer numbers: n — the number of holographic statues initially located at the ACM, and m — the number of statues to be added (2 ≤ n ≤ 1000, 1 ≤ m ≤ 1000). The length of the alley along the park perimeter is exactly 10 000 feet.

Output

Write a single real number to the output file — the minimal sum of travel distances of all statues (in feet). The answer must be precise to at least 4 digits after decimal point.

Sample Input

sample input #1
2 1

sample input #2
2 3

sample input #3
3 1

sample input #4
10 10

Sample Output

sample output #1
1666.6667

sample output #2
1000.0

sample output #3
1666.6667

sample output #4
0.0

Hint

Pictures show the first three examples. Marked circles denote original statues, empty circles denote new equidistant places, arrows denote movement plans for existing statues.

 题意:周长10000的圆上有n个雕塑,加入m个,要求雕塑最后等距放置,求原来n个雕塑的最小移动距离。

  思路:这个问题需要明确可以始终存在的情况是,加入m个雕塑后有一点没有移动,感觉这个挺简单的,证明的话不会。

  只需要将其他移动的点(假设有一点没有移动,这是求最小移动距离的充要条件),向没有移动的点的方向(即离其最近的那个方向)移动,先将比例求出来,再求移动距离

#include<iostream>//代码虽短,却非常不简单啊
#include<cstdio>
#include<cmath>
using namespace std;

int main()
{
    int n,m;
    while(scanf("%d%d",&n,&m) != EOF)
    {
        double ans = 0.0;
        for(int i = 1;i < n;i++)
        {
            double pos = (double)(n+m)/n*i;
            ans += fabs(pos - floor(pos + 0.5)) / (n+m);
        }
        printf("%.4f\n",ans*10000);
    }
    return 0;
}

注意一下floor函数的使用,向上取整

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值