POJ-2299 Ultra-QuickSort(树状数组)(离散化)

Ultra-QuickSort
Time Limit: 7000MS Memory Limit: 65536K
Total Submissions: 56014 Accepted: 20694

Description

In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence  
9 1 0 5 4 ,

Ultra-QuickSort produces the output  
0 1 4 5 9 .

Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.

Input

The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.

Output

For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.

Sample Input

5
9
1
0
5
4
3
1
2
3
0

Sample Output

6
0

Source


  树状数组求逆序数。由于数组元素最大达到999,999,999,所以不能直接开数组,要先用“离散化”的方法将数组元素映射成1~n,再进行一般的树状数组操作。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long ll;
const int N = 500005;
struct node
{
    int val,pos;
}nod[N];
int C[N],r[N];
int n;
bool cmp(node a,node b)
{
    return a.val < b.val;
}
int lowbit(int t)
{
    return t&(-t);
}
void add(int t)
{
    while(t <= n)
    {
        C[t] += 1;
        t += lowbit(t);
    }
}
//求得前面小于当前的数的个数
int getnum(int t)
{
    int ans = 0;
    while(t > 0)
    {
        ans += C[t];
        t -= lowbit(t);
    }
    return ans;
}

int main()
{
    while(~scanf("%d",&n) && n)
    {
        memset(C,0,sizeof(C));

        for(int i = 1;i <= n;i++)
        {
            scanf("%d",&nod[i].val);
            nod[i].pos = i;
        }
        sort(nod+1, nod+1+n,cmp);//先sort
        for(int i = 1;i <= n;i++)//离散化处理
            r[nod[i].pos] = i;
        ll ans = 0,k;
        for(int i = 1;i <= n;i++)
        {
            add(r[i]);
            k = i - getnum(r[i]);
            ans += k;
        }
        printf("%lld\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值