HDU-1297 Children’s Queue(递推)(高精度)

Children’s Queue

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13954    Accepted Submission(s): 4596


Problem Description
There are many students in PHT School. One day, the headmaster whose name is PigHeader wanted all students stand in a line. He prescribed that girl can not be in single. In other words, either no girl in the queue or more than one girl stands side by side. The case n=4 (n is the number of children) is like
FFFF, FFFM, MFFF, FFMM, MFFM, MMFF, MMMM
Here F stands for a girl and M stands for a boy. The total number of queue satisfied the headmaster’s needs is 7. Can you make a program to find the total number of queue with n children?
 

Input
There are multiple cases in this problem and ended by the EOF. In each case, there is only one integer n means the number of children (1<=n<=1000)
 

Output
For each test case, there is only one integer means the number of queue satisfied the headmaster’s needs.
 

Sample Input
  
  
1 2 3
 

Sample Output
  
  
1 2 4
 

Author
SmallBeer (CML)
 

Source


  题意:

F:girl          M:boy

给你一个n,代表队列的容量及girl的数量,女孩不可以单独出现,求方法的总数。

思路:

设a[i]代表此时的总数。

因为女孩不可以单独出现,所以队列最后的情况可能是一个boy(M),两个girl(F)。

M:前i-1个人肯定是满足要求的,所以次数为 a[i-1]

FF:

1.前i-2个满足要求,所以次数为a[i-2]

2.前i-2个不满足要求,所以就是MF+FF了,所以次数为a[i-4]

所以递推式就出来了,a[i] = a[i-1] + a[i-2] + a[i-4]

因为n最大1000,所以太大了,高精度。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
long long a[1005][105]={0};
void Init()
{
    int i,j;
    a[1][0] = 1;
    a[2][0] = 2;
    a[3][0] = 4;
    a[4][0] = 7;
    for(i = 5;i <= 1000;i++)
    {
        for(j = 0;j <= 100;j++)
        {
            a[i][j] += a[i-1][j] + a[i-2][j] + a[i-4][j];
            a[i][j+1] += a[i][j] / 10000;
            a[i][j] %= 10000;
        }
    }
}
int main()
{
    int n;
    Init();
    while(~scanf("%d",&n))
    {
        int j;
        for(j = 100;j >= 0;j--)
        {
            if(a[n][j] != 0)
            {
                printf("%d",a[n][j]);
                break;
            }
        }
        for(j = j-1;j >= 0;j--)
            printf("%04d",a[n][j]);
        printf("\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值