HDU-5883 The Best Path(欧拉通路和欧拉回路)

The Best Path

Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 952    Accepted Submission(s): 394


Problem Description
Alice is planning her travel route in a beautiful valley. In this valley, there are   N  lakes, and   M  rivers linking these lakes. Alice wants to start her trip from one lake, and enjoys the landscape by boat. That means she need to set up a path which go through every river exactly once. In addition, Alice has a specific number ( a1,a2,...,an ) for each lake. If the path she finds is   P0P1...Pt , the lucky number of this trip would be   aP0XORaP1XOR...XORaPt . She want to make this number as large as possible. Can you help her?
 

Input
The first line of input contains an integer   t , the number of test cases.   t  test cases follow.

For each test case, in the first line there are two positive integers   N (N100000)  and   M (M500000) , as described above. The   i -th line of the next   N  lines contains an integer   ai(i,0ai10000)  representing the number of the   i -th lake.

The   i -th line of the next   M  lines contains two integers   ui  and   vi  representing the   i -th river between the   ui -th lake and   vi -th lake. It is possible that   ui=vi .
 

Output
For each test cases, output the largest lucky number. If it dose not have any path, output "Impossible".
 

Sample Input
  
  
2 3 2 3 4 5 1 2 2 3 4 3 1 2 3 4 1 2 2 3 2 4
 

Sample Output
  
  
2 Impossible
 

Source
 

题意:n点m边,点有权,求是否可以经过每条边当且仅且一次(即是否存在欧拉通路或欧拉回路),如果可以,求出最大异或值(没经过一个点,异或其权值)。
思路:先判断是否存在欧拉通路或欧拉回路(无向图),按照定理:
当且仅当G是连通图且恰好有两个奇度顶点,G是欧拉通路无欧拉回路。
当且仅当G是连通图且无奇度顶点,G是欧拉回路。

不用判断连通的,如果有孤立点,就没有了边,自然无欧拉通路,题目说river当且仅当一次。

如果满足了情况,只需要异或经过奇数次的,注意经过次数和度数不一样。
然后对欧拉回路找起点,起点经过两次。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int N = 100005;
int deg[N],a[N];
int main()
{
    int t,n,m;
    cin >> t;
    while(t--)
    {
        scanf("%d%d",&n,&m);
        for(int i = 1;i <= n;i++)
            scanf("%d",&a[i]);

        memset(deg,0,sizeof(deg));
        int u,v;
        for(int i = 0;i < m;i++)
        {
            scanf("%d%d",&u,&v);
            deg[u]++,deg[v]++;
        }

        //欧拉
        int tot = 0;
        for(int i = 1;i <= n;i++)
        {
            if(deg[i] % 2)
                tot++;
        }

        if(tot != 2 && tot != 0)//欧拉回路和通路
        {
            printf("Impossible\n");
            continue;
        }

        int ans = 0;
        for(int i = 1;i <= n;i++)
        {
            deg[i] = (deg[i]+1)/2;//经过点的次数
            if(deg[i] % 2)//偶数次的不需要异或
                ans ^= a[i];
        }
        
        if(tot == 0)//存在欧拉回路的情况,我们要枚举起点,找到最大值
        {
            for(int i = 1;i <= n;i++)
                ans = max(ans , ans^a[i]);
        }
        printf("%d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值