1048 Find Coins (25 point(s)) - C语言 PAT 甲级

1048 Find Coins (25 point(s))

Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she could only use exactly two coins to pay the exact amount. Since she has as many as 105 coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find two coins to pay for it.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (≤ 105, the total number of coins) and M (≤ 103, the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers no more than 500. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the two face values V1 and V2 (separated by a space) such that V1 + V2 = M and V1 ≤ V2. If such a solution is not unique, output the one with the smallest V1. If there is no solution, output No Solution instead.

Sample Input:

8 15
1 2 8 7 2 4 11 15

Sample Output:

4 11

Sample Input:

7 14
1 8 7 2 4 11 15

Sample Output:

No Solution

题目大意:

输入 N 个数,求两个数 V1 + V2 = M 且 V1 ≤ V2,若有多对,则输出 V1 最小的一对

设计思路:
  • 利用数组和数组索引存每个数出现的次数,遍历寻找到第一对符合条件的,即可输出,
  • 因为遍历过程中,索引从小到大,相当于数值从小到大遍历,可以保证 V1 是最小值
编译器:C (gcc)
#include <stdio.h>

int main(void)
{
        int n, m, temp;
        int map[501] = {0};
        int i;

        scanf("%d %d", &n, &m);
        for (i = 0; i < n; i++) {
                scanf("%d", &temp);
                map[temp]++;
        }

        for (i = 0; i < 501; i++) {
                if (map[i]) {
                        map[i]--;
                        temp = m - i;
                        if (0 <= temp && temp <= 500 && map[temp]) {
                                printf("%d %d", i, temp);
                                return 0;
                        }
                        map[i]++;
                }
        }
        printf("No Solution");

        return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值