1073 Scientific Notation (20point(s)) - C语言 PAT 甲级

1073 Scientific Notation (20point(s))

Scientific notation is the way that scientists easily handle very large numbers or very small numbers. The notation matches the regular expression [±][1-9].[0-9]+E[±][0-9]+ which means that the integer portion has exactly one digit, there is at least one digit in the fractional portion, and the number and its exponent’s signs are always provided even when they are positive.

Now given a real number A in scientific notation, you are supposed to print A in the conventional notation while keeping all the significant figures.

Input Specification:

Each input contains one test case. For each case, there is one line containing the real number A in scientific notation. The number is no more than 9999 bytes in length and the exponent’s absolute value is no more than 9999.

Output Specification:

For each test case, print in one line the input number A in the conventional notation, with all the significant figures kept, including trailing zeros.

Sample Input:

+1.23400E-03

Sample Output:

0.00123400

Sample Input:

-1.2E+10

Sample Output:

-12000000000

题目大意:

1024 科学计数法 (20point(s))

设计思路:

1024 科学计数法(C语言)

  1. 数字的正负号决定输出普通数字的正负
  2. 指数的正负号决定小数点的移动
编译器:C (gcc)
#include <stdio.h>
#include <string.h>

int movepoint(char n[], int index);/*当指数为正,向右移动小数点*/
/*此函数用 '\0' 判断补 0 和输出小数点,数组至少需要 10002 个空间,定义 n[10003]*/

int rightprint(char n[], int index);
/*此函数利用指针直接循环输出,数组空间达题目要求即可,定义 n[10000](参考源码来自https://oliverlew.github.io/PAT/Basic/1024.html)*/

int main()
{
    int index;
    char n[10003] = {'\0'};
    scanf("%[^E]E%d", n, &index);
    if(n[0] == '-') printf("-");
    if(index >= 0){
        movepoint(n, index);
        printf("%s\n", n+1);
    }
    else{
        printf("0.");
        for(index++; index; index++){
            printf("0");
        }
        printf("%c%s\n", n[1], n+3);
    }
    return 0;
}

int movepoint(char n[], int index)
{
    char *p = n+2;
    for(; index; index--){
        if(*(p+1) != '\0') *p = *(p+1);
        else               *p = '0';
        p++;
        *p = '.';
    }
    if(*(p+1) == '\0') *p = '\0';
    return 0;
}

int rightprint(char n[], int index)
{
    char *p = n+1;
    putchar(*p);
    for(p += 2; index; index--){
        putchar(*p ? *p++ : '0');
    }
    if(*p)
    {
        putchar('.');
        while(*p) putchar(*p++);
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值