1102 Invert a Binary Tree (25point(s)) - C语言 PAT 甲级

1102 Invert a Binary Tree (25point(s))

The following is from Max Howell @twitter:

Google: 90% of our engineers use the software you wrote (Homebrew), but you can’t invert a binary tree on a whiteboard so fuck off.

Now it’s your turn to prove that YOU CAN invert a binary tree!

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10) which is the total number of nodes in the tree – and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node from 0 to N−1, and gives the indices of the left and right children of the node. If the child does not exist, a - will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in the first line the level-order, and then in the second line the in-order traversal sequences of the inverted tree. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:
8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6
Sample Output:

3 7 2 6 4 0 5 1
6 5 7 4 3 2 0 1

题目大意:

输入 N 个树的节点,依次给出节点的左右孩子节点序号

输出该树反转后的层序序列,中序序列

设计思路:

树的反转是指,每个节点的左右子树都做一次交换

  • 输出遍历序列时,其实就是先访问右子树,再访问左子树
  • 找到没有父节点的根节点,按照先右子树再左子树遍历输出
编译器:C (gcc)
#include <stdio.h>
#include <stdlib.h>

int tree[20][2];

void levelorder(int root)
{
        int q[20] = {root}, front = 0, rear = 1, cnt = 1;
        while (cnt > 0) {
                root = q[front];
                front++;
                cnt--;
                printf("%s%d", front > 1 ? " " : "", root);
                if (tree[root][0] != -1) {
                        q[rear] = tree[root][0];
                        rear++;
                        cnt++;
                }
                if (tree[root][1] != -1) {
                        q[rear] = tree[root][1];
                        rear++;
                        cnt++;
                }
        }
}

int flag = 0;
void inorder(int root)
{
        if (root == -1)
                return ;
        inorder(tree[root][0]);
        printf("%s%d", flag > 0 ? " " : "", root);
        flag = 1;
        inorder(tree[root][1]);
}

int main(void)
{
        int n;
        int i, root = 0, child[20] = {0};
        char a[3], b[3];

        scanf("%d", &n);
        for (i = 0; i < n; i++) {
                scanf("%s %s", a, b);
                if (a[0] != '-') {
                        tree[i][1] = atoi(a);
                        child[atoi(a)] = 1;
                } else {
                        tree[i][1] = -1;
                }
                if (b[0] != '-') {
                        tree[i][0] = atoi(b);
                        child[atoi(b)] = 1;
                } else {
                        tree[i][0] = -1;
                }
        }

        while (child[root] == 1)
                root++;
        levelorder(root);
        puts("");
        inorder(root);
        return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值