PAT (Advanced Level) 1102 Invert a Binary Tree (25 分)

1102 Invert a Binary Tree (25 分)

The following is from Max Howell @twitter:

Google: 90% of our engineers use the software you wrote (Homebrew), but you can't invert a binary tree on a whiteboard so fuck off.

Now it’s your turn to prove that YOU CAN invert a binary tree!

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10) which is the total number of nodes in the tree – and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node from 0 to N−1, and gives the indices of the left and right children of the node. If the child does not exist, a - will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in the first line the level-order, and then in the second line the in-order traversal sequences of the inverted tree. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:

8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6

Sample Output:

3 7 2 6 4 0 5 1
6 5 7 4 3 2 0 1

Code:

#include <iostream>
#include <vector>
#include <queue>
#pragma warning(disable:4996)
using namespace std;

struct Node
{
	int l, r;
	Node() { l = r = -1; }
};

vector<Node> tree; // 找root后完成层次遍历和中序遍历

void levelOrder(int root)
{
	queue<int> q;
	q.push(root);
	int cnt = 0;
	while (!q.empty())
	{
		int t = q.front();
		q.pop();
		cnt++;
		printf("%d%c", t, (cnt == tree.size() ? '\n' : ' '));
		if (tree[t].l != -1) q.push(tree[t].l);
		if (tree[t].r != -1) q.push(tree[t].r);
	}
}

int in_cnt = 0;
void inOrder(int root)
{
	if (root == -1)
		return;
	inOrder(tree[root].l);
	in_cnt++;
	printf("%d%c", root, (in_cnt == tree.size() ? '\n' : ' '));
	inOrder(tree[root].r);
}

int main()
{
	int n;
	scanf("%d", &n);
	tree.resize(n);
	vector<int> isRoot(n, 1);
	for (int i = 0; i < n; i++)
	{
		char l, r;
		getchar();
		scanf("%c %c", &l, &r);
		if (r != '-')
		{
			tree[i].l = r - '0';
			isRoot[r - '0'] = 0;
		}
		if (l != '-')
		{
			tree[i].r = l - '0';
			isRoot[l - '0'] = 0;
		}
	}
	int root;
	for (int i = 0; i < isRoot.size(); i++)
		if (isRoot[i]) root = i;
	levelOrder(root);
	inOrder(root);
	return 0;
}

思路:

注意点:scanf("%c", &ch)的时候,不会自动过滤\n 和 ‘ ’(即回车和空格)

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值