1108 Finding Average (20point(s)) - C语言 PAT 甲级

1108 Finding Average (20point(s))

The basic task is simple: given N real numbers, you are supposed to calculate their average. But what makes it complicated is that some of the input numbers might not be legal. A legal input is a real number in [−1000,1000] and is accurate up to no more than 2 decimal places. When you calculate the average, those illegal numbers must not be counted in.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then N numbers are given in the next line, separated by one space.

Output Specification:

For each illegal input number, print in a line ERROR: X is not a legal number where X is the input. Then finally print in a line the result: The average of K numbers is Y where K is the number of legal inputs and Y is their average, accurate to 2 decimal places. In case the average cannot be calculated, output Undefined instead of Y. In case K is only 1, output The average of 1 number is Y instead.

Sample Input:

7
5 -3.2 aaa 9999 2.3.4 7.123 2.35

Sample Output:

ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38

Sample Input:

2
aaa -9999

Sample Output:

ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined

题目大意:

1054 求平均值 (20point(s))

设计思路:

1054 求平均值(C语言)

  1. 用 scanf("%8s", str) 处理输入,因为”合法“输入最大字节数为 8 字节,所以一次读取 8 个字节或遇到空字符停止读取
  2. double strtod(const char *str, char **endptr) 函数转换字符串为浮点数
  3. char *strchr(const char *str, int c) 函数找小数点的位置
编译器:C (gcc)
#include <stdio.h>
#include <stdlib.h>
#include <string.h>

int main()
{
        int n, count = 0;
        double f, sum = 0;
        char s[9], *send, *sdot, c;

        scanf("%d", &n);
        while (n--) {
                scanf("%8s", s);
                c = ungetc(getchar(), stdin);
                f = strtod(s, &send);
                sdot = strchr(s, '.');

                if(!isspace(c)
                || *send
                || (f> 1000 || f < -1000)
                || (sdot && sdot - s < strlen(s) - 3)) {
                        printf("ERROR: %s", s);
                        while (!isspace(c = getchar()))
                                putchar(c);
                        printf(" is not a legal number\n");
                } else {
                        count++;
                        sum += f;
                }
        }

        if (count == 0)
                printf("The average of 0 numbers is Undefined\n");
        else if (count == 1)
                printf("The average of 1 number is %.2lf", sum);
        else
                printf("The average of %d numbers is %.2lf", count, sum/count);

        return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值