1112 Stucked Keyboard (20point(s)) - C语言 PAT 甲级

1112 Stucked Keyboard (20point(s))

On a broken keyboard, some of the keys are always stucked. So when you type some sentences, the characters corresponding to those keys will appear repeatedly on screen for k times.

Now given a resulting string on screen, you are supposed to list all the possible stucked keys, and the original string.

Notice that there might be some characters that are typed repeatedly. The stucked key will always repeat output for a fixed k times whenever it is pressed. For example, when k=3, from the string thiiis iiisss a teeeeeest we know that the keys i and e might be stucked, but s is not even though it appears repeatedly sometimes. The original string could be this isss a teest.

Input Specification:

Each input file contains one test case. For each case, the 1st line gives a positive integer k (1<k≤100) which is the output repeating times of a stucked key. The 2nd line contains the resulting string on screen, which consists of no more than 1000 characters from {a-z}, {0-9} and _. It is guaranteed that the string is non-empty.

Output Specification:

For each test case, print in one line the possible stucked keys, in the order of being detected. Make sure that each key is printed once only. Then in the next line print the original string. It is guaranteed that there is at least one stucked key.

Sample Input:

3
caseee1__thiiis_iiisss_a_teeeeeest

Sample Output:

ei
case1__this_isss_a_teest

题目大意:

有些按键损坏,输入正整数 K,表示按一次会重复 K 次,输入一段字符,根据字符串,寻找损坏的键,

按照坏键发现的顺序输出坏键,并按照正常按键输出修正后的字符串

设计思路:
  • 预先假设所有键盘都坏了,根据字符串标记好的键
  • 只要有一次 (连续相同字符)% K != 0 就说明此键是好的

注意:

  • 如果预先假设键盘良好,进而标记坏键,其实依旧需要标记遍历过程中发现的好键,例如,输入 2 abaa
  • 仅标记坏键的话,会误判 a 为坏键
  • 这是因为不能依据一次坏记录,就判断按键已坏,所有次记录都是坏的,才能判断已坏,
  • 而判断好键则相反,一次好记录就足以说明是好键
编译器:C (gcc)
#include <stdio.h>
#include <string.h>

int main(void)
{
        char str[1010] = {'\0'};
        int k;
        int flag[128] = {0};// 0 huai le
        int i, j, len;

        scanf("%d %s", &k, str);
        len = strlen(str);
        for (i = 0; i < len; i++) {
                j = i + 1;
                while (j < len && str[j] == str[i])
                        j++;
                if ((j - i) % k != 0)
                        flag[str[i]] = 1;
                i = j - 1;
        }
        int out[128] = {0};
        for (i = 0; i < len; i++) {
                if (flag[str[i]] == 0 && out[str[i]] == 0) {
                        printf("%c", str[i]);
                        out[str[i]] = 1;
                }
        }
        puts("");
        for (i = 0; i < len; i++) {
                printf("%c", str[i]);
                if (flag[str[i]] == 0)
                        i += (k - 1);
        }
        return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值