1112 Stucked Keyboard (20 point(s))

On a broken keyboard, some of the keys are always stucked. So when you type some sentences, the characters corresponding to those keys will appear repeatedly on screen for ktimes.

Now given a resulting string on screen, you are supposed to list all the possible stucked keys, and the original string.

Notice that there might be some characters that are typed repeatedly. The stucked key will always repeat output for a fixed k times whenever it is pressed. For example, when k=3, from the string thiiis iiisss a teeeeeest we know that the keys i and e might be stucked, but s is not even though it appears repeatedly sometimes. The original string could be this isss a teest.

Input Specification:

Each input file contains one test case. For each case, the 1st line gives a positive integer k (1<k≤100) which is the output repeating times of a stucked key. The 2nd line contains the resulting string on screen, which consists of no more than 1000 characters from {a-z}, {0-9} and _. It is guaranteed that the string is non-empty.

Output Specification:

For each test case, print in one line the possible stucked keys, in the order of being detected. Make sure that each key is printed once only. Then in the next line print the original string. It is guaranteed that there is at least one stucked key.

Sample Input:

3
caseee1__thiiis_iiisss_a_teeeeeest

Sample Output:

ei
case1__this_isss_a_teest

题目大意:给一个整数k,给一个字符串 s,若s中某个字符总以k的次数倍出现,则它为可能为坏了的键。输出可能坏的键和源字符串中坏键只出现一次的字符串。

分析:这种正反两面(好坏)的问题肯定是要用到标记的。现在问题在于标记好的字符还是坏的字符?对于某个字符,只要它有一处出现的次数不是k的整数倍,那么它对应的按键就是好的。显然,标记好的按键能满足条件。

1)开两个游标i,j扫描字符串,遇到不是出现k整数倍的字符就标记一下;否则,累加到ans上(ans用于暂存可能坏了的按键,但也可能将好的按键放进去哦  )

2)遍历ans,如果ans【】对应是坏件则输出(坏件只输出一次,再开个vis【】标记下)

3)   遍历s【】,判断输出

完整代码:

#include<bits/stdc++.h>
using namespace std;
int well[1010],vis[1010];
int main(){
	int k;
	string s,ans; //ans里面存可能坏的键 
	cin>>k>>s;
    for(int i=0;i<s.length();){
    	int j=i;
    	while(j<s.length() && s[i]==s[j]) j++;
		if((j-i)%k!=0) well[s[i]]=true; 
		else ans+=s[i];// ans里面存的可能坏的键,
		i=j;
    }
    for(int i=0;i<ans.length();i++){
    	if(well[ans[i]]==false && vis[ans[i]]==0){
    		cout<<ans[i];
    		vis[ans[i]]=true;
		}
    }
    cout<<endl;
    for(int i=0;i<s.length();i++){
    	cout<<s[i];
    	if(well[s[i]]==false) i+=(k-1);
    }
    return 0;
}

That‘s all !

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

ZCAIHUI_

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值