1124 Raffle for Weibo Followers (20point(s))
John got a full mark on PAT. He was so happy that he decided to hold a raffle(抽奖) for his followers on Weibo – that is, he would select winners from every N followers who forwarded his post, and give away gifts. Now you are supposed to help him generate the list of winners.
Input Specification:
Each input file contains one test case. For each case, the first line gives three positive integers M (≤ 1000), N and S, being the total number of forwards, the skip number of winners, and the index of the first winner (the indices start from 1). Then M lines follow, each gives the nickname (a nonempty string of no more than 20 characters, with no white space or return) of a follower who has forwarded John’s post.
Note: it is possible that someone would forward more than once, but no one can win more than once. Hence if the current candidate of a winner has won before, we must skip him/her and consider the next one.
Output Specification:
For each case, print the list of winners in the same order as in the input, each nickname occupies a line. If there is no winner yet, print Keep going… instead.
Sample Input:
9 3 2
Imgonnawin!
PickMe
PickMeMeMeee
LookHere
Imgonnawin!
TryAgainAgain
TryAgainAgain
Imgonnawin!
TryAgainAgain
Sample Output:
PickMe
Imgonnawin!
TryAgainAgain
Sample Input:
2 3 5
Imgonnawin!
PickMe
Sample Output:
Keep going…
题目大意:
设计思路:
- 用数组记录获奖人的姓名
- 用 s + count x n + r 计算中奖人的号码
编译器:C (gcc)
#include <stdio.h>
#include <string.h>
int main()
{
char names[1000][21] = {{'\0'}}, line[21];
int m, n, s;
int i, j, flag, count = 0, r = 0;
scanf("%d %d %d", &m, &n, &s);
for (i = 0, s--; i < m; i++) {
scanf("%s", line);
if (i == s + count * n + r) {
flag = 1;
for (j = 0; j < count && flag; j++)
if (!strcmp(names[j], line)) {
flag = 0;
r++;
break;
}
if (flag) {
puts(line);
strcpy(names[count++], line);
}
}
}
if (!count)
printf("Keep going...\n");
return 0;
}