Drainage Ditches

Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie's clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch. 
Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network. 
Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle. 

Input

The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch. 

Output

For each case, output a single integer, the maximum rate at which water may emptied from the pond. 

Sample Input

5 4
1 2 40
1 4 20
2 4 20
2 3 30
3 4 10

Sample Output

50

题意:N个点,从第一个点最多可以运多少东西到n点。

思路:是道最大流问题,可以直接用模板,求出最大流。

#include<stdio.h>
#include<math.h>
#include<string.h>
#include<algorithm>
#include<queue>
using namespace std;
#define inf 0x3f3f3f3f
int n,m,s[210],vis[210],map[210][210];
int bfs()
{
    queue<int>Q;
    memset(vis,-1,sizeof(vis));
    vis[1]=0;
    s[1]=inf;
    Q.push(1);
    while(!Q.empty())
    {
        int now=Q.front();
        Q.pop();
        for(int i=1; i<=m; i++)
        {
            if(i!=1&&map[now][i]&&vis[i]==-1)
            {
                vis[i]=now;
                s[i]=min(map[now][i],s[now]);
                Q.push(i);
            }
        }
    }
    if(vis[m]==-1)
        return -1;
    return s[m];
}
int dfs()
{
    int sum=0,temp,num,ans;
    while(1)
    {
        temp=bfs();
        if(temp==-1)break;
        sum+=temp;
        num=m;
        while(num!=1)
        {
            ans=vis[num];
            map[ans][num]-=temp;
            map[num][ans]+=temp;
            num=ans;
        }
    }
    return sum;
}
int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        int a,b,c,i;
        memset(map,0,sizeof(map));
        for(i=0; i<n; i++)
        {
            scanf("%d %d %d",&a,&b,&c);
            map[a][b]+=c;
        }
        int sum=dfs();
        printf("%d\n",sum);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值