ACM ICPC 1045 Bode Plot

10 篇文章 0 订阅
6 篇文章 0 订阅

欢迎前往个人博客 驽马点滴 和视频空间 哔哩哔哩-《挨踢日志》

Bode Plot
Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 9155Accepted: 6067

Description

Consider the AC circuit below. We will assume that the circuit is in steady-state. Thus, the voltage at nodes 1 and 2 are given by v1 = VS coswt and v2 = VRcos (wt + q ) where VS is the voltage of the source, w is the frequency (in radians per second), and t is time. VR is the magnitude of the voltage drop across the resistor, and q is its phase.


You are to write a program to determine VR for different values of w. You will need two laws of electricity to solve this problem. The first is Ohm's Law, which states v2 = iR where i is the current in the circuit, oriented clockwise. The second is i = C d/dt (v1-v2) which relates the current to the voltage on either side of the capacitor. "d/dt"indicates the derivative with respect to t.

Input

The input will consist of one or more lines. The first line contains three real numbers and a non-negative integer. The real numbers are VS, R, and C, in that order. The integer, n, is the number of test cases. The following n lines of the input will have one real number per line. Each of these numbers is the angular frequency, w.

Output

For each angular frequency in the input you are to output its corresponding VR on a single line. Each VR value output should be rounded to three digits after the decimal point.

Sample Input

1.0 1.0 1.0 90.010.0316230.10.316231.03.162310.031.623100.0

Sample Output

0.0100.0320.1000.3020.7070.9530.9951.0001.000

 

【说明】联立方程,求解可以得到VR的表达式。

【程序】

#include<iostream>
#include<iomanip>
using namespace std;
#include<cmath>
int main()
{
	double Vs;
	double R;
	double C;
	int n;
	double w;
	double result[10];
	cin >> Vs >> R >> C >> n;
	for (int i = 0; i < n; ++i)
	{
		cin>>w;
		w = R*C*w;
		result[i] = w*Vs/sqrt(1+w*w);
	}
	for (int j= 0; j < n; ++j)
	{
		cout << setiosflags(ios::fixed) << setprecision(3) << result[j] << endl;
	}
	return 0;
}

欢迎前往个人博客 驽马点滴 和视频空间 哔哩哔哩-《挨踢日志》

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值