HDU 5914 Triangle【找规律】【2016中国大学生程序设计竞赛(长春)】

Triangle

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 578    Accepted Submission(s): 382


Problem Description
Mr. Frog has n sticks, whose lengths are 1,2, 3 n respectively. Wallice is a bad man, so he does not want Mr. Frog to form a triangle with three of the sticks here. He decides to steal some sticks! Output the minimal number of sticks he should steal so that Mr. Frog cannot form a triangle with
any three of the remaining sticks.
 

Input
The first line contains only one integer T ( T20 ), which indicates the number of test cases. 

For each test case, there is only one line describing the given integer n ( 1n20 ).
 

Output
For each test case, output one line “Case #x: y”, where x is the case number (starting from 1), y is the minimal number of sticks Wallice should steal.
 

Sample Input
  
  
3 4 5 6
 

Sample Output
  
  
Case #1: 1 Case #2: 1 Case #3: 2
 

Source

原题链接:http://acm.hdu.edu.cn/showproblem.php?pid=5914

题意:有n根长度为1-n的木棍,问你最少拿去多少根,使得剩下的不能构成三角形。

经过推测,使得剩下的木棍长度构成Fibobacci数列,就不能构成三角形。

有人直接写答案,但是20个数有点烦,能用循环解决的就不用‘暴力’。

AC代码:

#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
const int maxn=25;
bool vis[maxn];
int ans[maxn];
int main()
{
    int x=0,y=1;
    vis[1]=true;
    while(true)
    {
        vis[x]=true;
        y+=x;
        x=y-x;
        if(y>maxn)
            break;
    }
    int cnt=0;
    for(int i=0; i<maxn; i++)
    {
        if(!vis[i])
            cnt++;
        ans[i]=cnt;
    }
    int T,kase=0;
    cin>>T;
    int n;
    while(T--)
    {
        cin>>n;
        printf("Case #%d: %d\n",++kase,ans[n]);
    }
    return 0;
}

尊重原创,转载请注明出处: http://blog.csdn.net/hurmishine



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值