钱币兑换问题


Problem Description
在一个国家仅有1分,2分,3分硬币,将钱N兑换成硬币有很多种兑法。请你编程序计算出共有多少种兑法。
Input
每行只有一个正整数N,N小于32768。
Output
对应每个输入,输出兑换方法数。
Sample Input
2934
12553
Sample Output
718831
13137761


import java.util.Scanner;


public class Coins {

	public static void main(String[] args) {
		int money;
		@SuppressWarnings("resource")
		Scanner sc = new Scanner(System.in);
		while(sc.hasNext()){
			money = sc.nextInt();
			System.out.println(NumberCase(money));
		}
	}
	
	public static  int NumberCase(int N){
		int sum = 0;
		int upcase = N/3;
		for(int i=0;i<=upcase;i++){
			sum+= (N - 3*i)/2 +1;
		}
		return sum;
	}
}

因为其实简单理解成 n = 1*x + 2*y + 3*z 

首先先确定有多少个3,然后n 减去 3*z ,得到剩余值除以2 确定有多少个2,然后1的个数自然确定啦。

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值