hdu 5120 Intersection

Intersection

Time Limit: 4000/4000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others)
Total Submission(s): 146    Accepted Submission(s): 63


Problem Description
Matt is a big fan of logo design. Recently he falls in love with logo made up by rings. The following figures are some famous examples you may know.


A ring is a 2-D figure bounded by two circles sharing the common center. The radius for these circles are denoted by r and R (r < R). For more details, refer to the gray part in the illustration below.


Matt just designed a new logo consisting of two rings with the same size in the 2-D plane. For his interests, Matt would like to know the area of the intersection of these two rings.
 

Input
The first line contains only one integer T (T ≤ 10 5), which indicates the number of test cases. For each test case, the first line contains two integers r, R (0 ≤ r < R ≤ 10).

Each of the following two lines contains two integers x i, y i (0 ≤ x i, y i ≤ 20) indicating the coordinates of the center of each ring.
 

Output
For each test case, output a single line “Case #x: y”, where x is the case number (starting from 1) and y is the area of intersection rounded to 6 decimal places.
 

Sample Input
  
  
2 2 3 0 0 0 0 2 3 0 0 5 0
 

Sample Output
  
  
Case #1: 15.707963 Case #2: 2.250778
 



#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
using namespace std;
const double w=1e-8;
const double IP=acos(-1.0);

struct node{
    double x,y;
}p,q;

double f(node a,double r,node b,double R){
    double d=sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
    if(d>r+R+w)  return 0;
    if(fabs(r-R)+w>d){
        int rr=min(r,R);
        return IP*rr*rr;
    }
    double x=(r*r+d*d-R*R)/(2*d);
    double g1=acos(x/r);
    double g2=acos((d-x)/R);
    return r*r*g1+R*R*g2-d*r*sin(g1);
}

int main(){
    int T,k=1;
    cin>>T;
    while(T--){
        double x1,x2,y1,y2,r1,r2;
        cin>>r1>>r2>>x1>>y1>>x2>>y2;
        q.x=x1,q.y=y1;
        p.x=x2,p.y=y2;
        double ans=f(q,r2,p,r2)-f(q,r1,p,r2)-f(q,r2,p,r1)+f(q,r1,p,r1);
        printf("CASE #%d: %.6lf\n",k++,ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值