hdu 5120 Intersection (圆相交面积模板)

Matt is a big fan of logo design. Recently he falls in love with logo made up by rings. The following figures are some famous examples you may know. 


A ring is a 2-D figure bounded by two circles sharing the common center. The radius for these circles are denoted by r and R (r < R). For more details, refer to the gray part in the illustration below. 


Matt just designed a new logo consisting of two rings with the same size in the 2-D plane. For his interests, Matt would like to know the area of the intersection of these two rings.
Input
The first line contains only one integer T (T ≤ 10  5), which indicates the number of test cases. For each test case, the first line contains two integers r, R (0 ≤ r < R ≤ 10). 

Each of the following two lines contains two integers x  i, y  i (0 ≤ x  i, y  i≤ 20) indicating the coordinates of the center of each ring.
Output
For each test case, output a single line “Case #x: y”, where x is the case number (starting from 1) and y is the area of intersection rounded to 6 decimal places. 
Sample Input
2
2 3
0 0
0 0
2 3
0 0
5 0
Sample Output
Case #1: 15.707963
Case #2: 2.250778

#include <cstdio>
#include <cstring>
#include <math.h>
#include <algorithm>
#include <iostream>
using namespace std;
#define maxn 100005
const double eps = 1e-5;
const double pi = acos (-1.0);
struct Point
{
     double x,y;
};
 double dist(Point a,Point b)
{
    return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
}
double Area(Point c1,double r1,Point c2,double r2)
{
    double d=dist(c1,c2);
    if(r1+r2<d+eps)return 0;
    if(d<fabs(r1-r2)+eps)
    {
        double r=min(r1,r2);
        return pi*r*r;
    }
    double x=(d*d+r1*r1-r2*r2)/(2*d);
    double t1=acos(x/r1);
    double t2=acos((d-x)/r2);
    return r1*r1*t1+r2*r2*t2-d*r1*sin(t1);
}
 double R,r;
Point O1,O2;
int main()
{
    int t;
     scanf("%d",&t);
     for(int cas=1;cas<=t;cas++)
     {
         scanf("%lf%lf",&r,&R);
         scanf("%lf%lf%lf%lf",&O1.x,&O1.y,&O2.x,&O2.y);
    double S=Area(O1,R,O2,R)-Area(O1,R,O2,r)-Area(O2,R,O1,r)+Area(O1,r,O2,r);

          printf("Case #%d: %.6lf\n",cas,S);
     }
    return 0;
}




  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值