A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:
- The left subtree of a node contains only nodes with keys less than the node's key.
- The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
- Both the left and right subtrees must also be binary search trees.
If we swap the left and right subtrees of every node, then the resulting tree is called the Mirror Image of a BST.
Now given a sequence of integer keys, you are supposed to tell if it is the preorder traversal sequence of a BST or the mirror image of a BST.
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (<=1000). Then N integer keys are given in the next line. All the numbers in a line are separated by a space.
Output Specification:
For each test case, first print in a line "YES" if the sequence is the preorder traversal sequence of a BST or the mirror image of a BST, or "NO" if not. Then if the answer is "YES", print in the next line the postorder traversal sequence of that tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.
Sample Input 1:7 8 6 5 7 10 8 11Sample Output 1:
YES 5 7 6 8 11 10 8Sample Input 2:
7 8 10 11 8 6 7 5Sample Output 2:
YES 11 8 10 7 5 6 8Sample Input 3:
7 8 6 8 5 10 9 11Sample Output 3:
NO
根据已知序列分别建立二叉搜索树和镜像二叉搜索树,然后分别判断是否与原序列相等,最后再输出它的后序序列。
#include<iostream>
using namespace std;
#include<string.h>
#include<stdio.h>
#include<queue>
#define MS(a,b) memset(a,b,sizeof(a))
typedef struct node
{
int data;
node *left,*right;
}*Tree;
Tree T;
int v1[2000],v2[2000],ans[2000],n;
void insert1(Tree &T,int num)//建立二叉搜索树
{
int i;
if(T==NULL)
{ T=new node();
T->data=num;
T->left=NULL;
T->right=NULL;
return ;
}
if(num<T->data)
insert1(T->left,num);
else insert1(T->right,num);
}
void insert2(Tree &T,int num)//建立镜像二叉搜索树
{
int i;
if(T==NULL)
{ T=new node();
T->data=num;
T->left=NULL;
T->right=NULL;
return ;
}
if(num>=T->data)
insert2(T->left,num);
else insert2(T->right,num);
}
int j,k;
void preorder(Tree T,int v[])
{
v[j++]=T->data;
if(T->left!=NULL)
preorder(T->left,v);
if(T->right!=NULL)
preorder(T->right,v);
}
void postorder(Tree T,int v[])
{
if(T->left!=NULL)
postorder(T->left,v);
if(T->right!=NULL)
postorder(T->right,v);
v[k++]=T->data;
}
int main()
{
/*#ifndef ONLINE_JUDGE
freopen("in.txt","r",stdin);
freopen("out.txt","w",stdout);
#endif*/
int n,i,num[2000],sign1=0,sign2=0;
scanf("%d",&n);
Tree T1=NULL,T2=NULL;
for(i=0;i<n;i++)
{
scanf("%d",&num[i]);
insert1(T1,num[i]);
insert2(T2,num[i]);
}
j=0;
preorder(T1,v1);
j=0;
preorder(T2,v2);
for(i=0;i<n;i++)
if(v1[i]!=num[i])
{sign1=1;break;}
for(i=0;i<n;i++)
if(v2[i]!=num[i])
{sign2=1;break;}
if(sign1&&sign2)
printf("NO\n");
else
{k=0;
if(!sign1&&sign2)
postorder(T1,ans);
else
postorder(T2,ans);
printf("YES\n");
for(i=0;i<k-1;i++)
printf("%d ",ans[i]);
printf("%d\n",ans[i]);
}
return 0;
}