PAT A1043. Is It a Binary Search Tree (25)

原文链接: PAT A1043. Is It a Binary Search Tree (25)

上一篇: PAT A1053. Path of Equal Weight (30)

下一篇: 1028. 人口普查(20)

1043. Is It a Binary Search Tree (25)

https://www.patest.cn/contests/pat-a-practise/1043

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

If we swap the left and right subtrees of every node, then the resulting tree is called the Mirror Image of a BST.

Now given a sequence of integer keys, you are supposed to tell if it is the preorder traversal sequence of a BST or the mirror image of a BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=1000). Then N integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in a line "YES" if the sequence is the preorder traversal sequence of a BST or the mirror image of a BST, or "NO" if not. Then if the answer is "YES", print in the next line the postorder traversal sequence of that tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

7
8 6 5 7 10 8 11

Sample Output 1:

YES
5 7 6 8 11 10 8

Sample Input 2:

7
8 10 11 8 6 7 5

Sample Output 2:

YES
11 8 10 7 5 6 8

Sample Input 3:

7
8 6 8 5 10 9 11

Sample Output 3:

NO

通过给定序列构建二叉树,对镜像树的先序遍历只需要在原树的先序遍历时交换左右子树的位置即可

#include <iostream>
#include <cstdio>
#include <vector>
using namespace std;

struct Node {
	int data;
	Node *left, *right;
	Node() {}
	Node(int data) :data(data) {
		left = right = NULL;
	}
};

//原始序列,前序,后序,镜像树的前和后序 
vector<int> origin, pre, post, preM, postM;
//插入函数 
void insert(Node* &root, int data) {
	if (root == NULL) {		//到达空节点时即是插入位置 
		root = new Node(data);
		return;
	}
	if (data < root->data)
		insert(root->right, data);
	else
		insert(root->left, data);
}

//先序遍历 
void preOrder(Node *root) {
	if (root == NULL)
		return;
	pre.push_back(root->data);
	preOrder(root->left);
	preOrder(root->right);
}

//镜像树的前序遍历
void preOrderM(Node *root) {
	if (root == NULL)
		return;
	preM.push_back(root->data);
	preOrderM(root->right);
	preOrderM(root->left);
}

//后序 
void postOrder(Node *root) {
	if (root == NULL)
		return;
	postOrder(root->left);
	postOrder(root->right);
	post.push_back(root->data);
}

//镜像树的后序
void postOrderM(Node *root) {
	if (root == NULL)
		return;
	postOrderM(root->right);
	postOrderM(root->left);
	postM.push_back(root->data);
}
int main(int argc, char *argv[]) {
	int n, t;
	scanf("%d", &n);
	Node *root = NULL;
	for (int i = 0; i < n; i++) {
		scanf("%d", &t);
		origin.push_back(t);
		insert(root, t);
	}
	preOrder(root);
	preOrderM(root);
	postOrderM(root);
	postOrder(root);

	if (origin == pre) {
		printf("YES\n");
		for (int i = 0; i < post.size(); i++)
			printf("%d%c", post[i], i == post.size() - 1 ? '\n' : ' ');
	} else if (origin == preM) {
		printf("YES\n");
		for (int i = 0; i < postM.size(); i++)
			printf("%d%c", postM[i], i == postM.size() - 1 ? '\n' : ' ');
	} else {
		printf("NO\n");
	}
	return 0;
}

题目大意:给定一个整数键值序列,现请你编写程序,判断这是否是对一棵二叉搜索树或其镜像进行前序遍历的结果。
分析:假设它是二叉搜索树,一开始isMirror为FALSE,根据二叉搜索树的性质将已知的前序转换为后序,转换过程中,如果发现最后输出的后序数组长度不为n,那就设isMirror为true,然后清空后序数组,重新再转换一次(根据镜面二叉搜索树的性质),如果依旧转换后数组大小不等于n,就输出no否则输出yes

#include <cstdio>
#include <vector>
using namespace std;
bool isMirror;
vector<int> pre;
vector<int> post;
void getpost(int root, int tail) {
    if(root > tail) return ;
    int i = root + 1, j = tail;
    if(!isMirror) {
        while(i <= tail && pre[root] > pre[i]) i++;
        while(j > root && pre[root] <= pre[j]) j--;
    } else {
        while(i <= tail && pre[root] <= pre[i]) i++;
        while(j > root && pre[root] > pre[j]) j--;
    }
    if(i - j != 1) return ;
    getpost(root + 1, j);
    getpost(i, tail);
    post.push_back(pre[root]);
}
int main() {
    int n;
    scanf("%d", &n);
    pre.resize(n);
    for(int i = 0; i < n; i++)
        scanf("%d", &pre[i]);
    getpost(0, n - 1);
    if(post.size() != n) {
        isMirror = true;
        post.clear();
        getpost(0, n - 1);
    }
    if(post.size() == n) {
        printf("YES\n%d", post[0]);
        for(int i = 1; i < n; i++)
            printf(" %d", post[i]);
    } else {
        printf("NO");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值