文章标题

26 篇文章 0 订阅

There is a mysterious planet called Yaen, whose space is 2-dimensional. There are many beautiful stones on the planet, and the Yaen people love to collect them. They bring the stones back home and make nice mobile arts of them to decorate their 2-dimensional living rooms.

In their 2-dimensional world, a mobile is defined recursively as follows:

a stone hung by a string, or
a rod of length 1 with two sub-mobiles at both ends; the rod is hung by a string at the center of gravity of sub-mobiles. When the weights of the sub-mobiles are n and m , and their distances from the center of gravity are a and b respectively, the equation n x a = m x b holds.
这里写图片描述
For example, if you got three stones with weights 1, 1, and 2, here are some possible mobiles and their widths:
这里写图片描述

Given the weights of stones and the width of the room, your task is to design the widest possible mobile satisfying both of the following conditions.

It uses all the stones.
Its width is less than the width of the room.
You should ignore the widths of stones. In some cases two sub-mobiles hung from both ends of a rod might overlap (see the figure on the right). Such mobiles are acceptable. The width of the example is (1/3) + 1 + (1/4) .
这里写图片描述

Input

The first line of the input gives the number of datasets. Then the specified number of datasets follow. A dataset has the following format.

r

s

w1

ws

r is a decimal fraction representing the width of the room, which satisfies 0 < r < 10 . s is the number of the stones. You may assume 1s6 . wi is the weight of the i -th stone, which is an integer. You may assume 1wi1000 .

You can assume that no mobiles whose widths are between r - 0.00001 and r + 0.00001 can be made of given stones.

Output

For each dataset in the input, one line containing a decimal fraction should be output. The decimal fraction should give the width of the widest possible mobile as defined above. An output line should not contain extra characters such as spaces.

In case there is no mobile which satisfies the requirement, answer `-1’ instead.

The answer should not have an error greater than 0.00000001. You may output any numb er of digits after the decimal point, provided that the ab ove accuracy condition is satisfied.

Sample Input

5
1.3
3
1
2
1
1.4
3
1
2
1
2.0
3
1
2
1
1.59
4
2
1
1
3
1.7143
4
1
2
3
5
Sample Output

-1
1.3333333333333335
1.6666666666666667
1.5833333333333335
1.7142857142857142

我有话说:
枚举吧。我们可以把这么一堆点划分为两个子树,然后递归处理每个子树。每个子树都看作一个节点,记录总重量。
枚举的办法可以用二进制。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <vector>
using namespace std;
const int maxn=6;
struct Tree{
  double L,R;
  Tree():L(0),R(0){}
};
int n,vis[1<<maxn];
double r,w[maxn],sum[1<<maxn];
vector <Tree> tree[1<<maxn];
void dfs(int root)
{
    if(vis[root])return;
    vis[root]=1;
    bool has_child=false;
    for(int left=(root-1)&root;left;left=(left-1)&root)
    {
        has_child=true;
        int right=root^left;
        double d1=sum[right]/sum[root];
        double d2=sum[left]/sum[root];
        dfs(left);dfs(right);
        for(int i=0;i<tree[left].size();i++)
        {
            for(int j=0;j<tree[right].size();j++)
            {
                Tree t;
                t.L=max(tree[left][i].L+d1,tree[right][j].L-d2);//
                t.R=max(tree[right][j].R+d2,tree[left][i].R-d1);//
                if(t.L+t.R<r)tree[root].push_back(t);
            }
        }
    }
    if(!has_child)tree[root].push_back(Tree());
}
int main()
{
    int T;
    cin>>T;
    while(T--)
    {
        scanf("%lf%d",&r,&n);
        for(int i=0;i<n;i++)
            scanf("%lf",&w[i]);
        for(int i=0;i<(1<<n);i++)
        {
            sum[i]=0;
            tree[i].clear();
            for(int j=0;j<n;j++)
            {
                if(i&(1<<j))sum[i]+=w[j];
            }

        }
        int root=(1<<n)-1;
        memset(vis,0,sizeof(vis));
        dfs(root);

        double ans=-1;
        for(int i=0;i<tree[root].size();i++)
        {
            ans=max(ans,tree[root][i].L+tree[root][i].R);
        }
        if(ans==-1)printf("-1\n");
        else printf("%.16lf\n",ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值