RXD and math

RXD is a good mathematician.
One day he wants to calculate:
i=1nkμ2(i)×nki

output the answer module  109+7 .
1n,k1018
μ(n)=1(n=1)

μ(n)=(1)k(n=p1p2pk)

μ(n)=0(otherwise)

p1,p2,p3pk  are different prime numbers
 

Input
There are several test cases, please keep reading until EOF.
There are exact 10000 cases.
For each test case, there are 2 numbers  n,k .
 

Output
For each test case, output "Case #x: y", which means the test case number and the answer.
 

Sample Input
  
  
10 10
 

Sample Output
  
  
Case #1: 999999937
 

Source
 

Recommend
liuyiding   |   We have carefully selected several similar problems for you:  6066 6065 6064 6063 6062 



解答过程:
这其实是个找规律题。
其中μ(i)为莫比乌斯函数。

p1p2p3.......pk代表不同的素数。
μ(n)有一下值。

根据这些结合题中信息。
知:
当n=1,k=1时结果为1
当n=2,k=1时结果为2
当n=2,k=2时结果为4
当n=3,k=1时结果为3
当n=3,k=2时结果为9
当n=1,k=1时结果为1
当n=3,k=3时结果为27

当n=10,k=10时结果为999999937
综上,结果为n的k次幂。
注意:由于数值很大注意取余。
具体代码:
#include <iostream>
#include<algorithm>
#include<cstdio>
const long long MOD=1e9+7;
int i=1;
void pow(long long n,long long k)
{
    long long ans=1;
    while(k)
    {
        if(k&1)
        {
            ans=((ans%MOD)*(n%MOD))%MOD;
        }
        n=((n%MOD)*(n%MOD))%MOD;
        k>>=1;
    }
    printf("Case #%d: %lld\n",i++,ans%MOD);

}
int main()
{
    long long n,k;
    while(scanf("%lld%lld",&n,&k)!=EOF)
    {
        pow(n,k);
    }
    return 0;
}


当n=1,k=1时结果为1
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值