pat-1050 String Subtraction(20)(巧用bool函数)

 

Given two strings S​1​​ and S​2​​, S=S​1​​−S​2​​ is defined to be the remaining string after taking all the characters in S​2​​ from S​1​​. Your task is simply to calculate S​1​​−S​2​​ for any given strings. However, it might not be that simple to do it fast.

Input Specification:

Each input file contains one test case. Each case consists of two lines which gives S​1​​ and S​2​​, respectively. The string lengths of both strings are no more than 10​4​​. It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.

Output Specification:

For each test case, print S​1​​−S​2​​ in one line.

Sample Input:

They are students.
aeiou

Sample Output:

Thy r stdnts.

作者: CHEN, Yue

单位: 浙江大学

时间限制: 100 ms

内存限制: 64 MB

代码长度限制: 16 KB

 

这题很巧妙,用个bool 函数很快就搞定了,好经典!而且值得注意的是,bool数组要默认是false,我试了一下,如果是默认true,就啥也输出不了...还是值得研究的! 

#include <iostream>
#include <algorithm>
#include <cmath>
#include <cstdlib>
#include <cstring>
#include <cstdio>
#include <vector>
using namespace std;
const int maxn = 1e4  + 5;
bool a[maxn] = {false};
char s1[maxn],s2[maxn];
int main()
{
    cin.getline(s1, maxn);
    cin.getline(s2, maxn);
    for(int i = 0;i < strlen(s2);i++)
        a[s2[i]] = true;
    for(int i = 0;i < strlen(s1);i++)
    {
        if(a[s1[i]] == false)
            printf("%c",s1[i]);
    }
    printf("\n");
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值