HDU 6225 Little Boxes (大数加法)

Little Boxes

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 2374    Accepted Submission(s): 845


Problem Description
Little boxes on the hillside.
Little boxes made of ticky-tacky.
Little boxes.
Little boxes.
Little boxes all the same.
There are a green boxes, and b pink boxes.
And c blue boxes and d yellow boxes.
And they are all made out of ticky-tacky.
And they all look just the same.
 

Input
The input has several test cases. The first line contains the integer t (1 ≤ t ≤ 10) which is the total number of test cases.
For each test case, a line contains four non-negative integers a, b, c and d where a, b, c, d ≤ 2^62, indicating the numbers of green boxes, pink boxes, blue boxes and yellow boxes.
 

Output
For each test case, output a line with the total number of boxes.
 

Sample Input
 
 
4 1 2 3 4 0 0 0 0 1 0 0 0 111 222 333 404
 

Sample Output
 
 
10 0 1 1070

/*
题意: 给n组数据,每组四个数,将四个数之和输出即可

思路: long long 会溢出,简单大数加法模拟。 

*/


#include<bits/stdc++.h>

using namespace std;

int bit[100],next1[100];


/*
	@function: 模拟计算 
	@param:	   next1[]:记录每位值的大小
			   bit[]  :记录加法后的结果 

*/
void cul(char *x){
	int len=strlen(x);
	reverse(x,x+len);				//倒置数组 
	memset(next1,0,sizeof next1);
	for(int i=0;i<len;i++) next1[i]=x[i]-'0';
	for(int i=0;i<len;i++){
		bit[i]+=next1[i];
		while(bit[i]>=10){
			bit[i+1]++;
			bit[i]-=10;
		}
	}
}


int main(){
	char a[100],b[100],c[100],d[100];
	int n;
	scanf("%d",&n);
	for(int i=0;i<n;i++){
		memset(bit,0,sizeof bit);
		cin>>a>>b>>c>>d;
		cul(a);
		cul(b);
		cul(c);
		cul(d);
		int f=0;
		//处理前置0 
		for(int i=99;i>=0;i--){
			if(bit[i]>0){
				f=i;
				break;
			}
		}
		for(int i=f;i>0;i--){
			printf("%d",bit[i]);
		}
		printf("%d\n",bit[0]);
	}
} 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值