poj 1850 Code

12 篇文章 0 订阅

 Code
Time Limit:1000MS     Memory Limit:30000KB     64bit IO Format:%lld & %llu

Description

Transmitting and memorizing information is a task that requires different coding systems for the best use of the available space. A well known system is that one where a number is associated to a character sequence. It is considered that the words are made only of small characters of the English alphabet a,b,c, ..., z (26 characters). From all these words we consider only those whose letters are in lexigraphical order (each character is smaller than the next character). 

The coding system works like this: 
• The words are arranged in the increasing order of their length. 
• The words with the same length are arranged in lexicographical order (the order from the dictionary). 
• We codify these words by their numbering, starting with a, as follows: 
a - 1 
b - 2 
... 
z - 26 
ab - 27 
... 
az - 51 
bc - 52 
... 
vwxyz - 83681 
... 

Specify for a given word if it can be codified according to this coding system. For the affirmative case specify its code. 

Input

The only line contains a word. There are some constraints: 
• The word is maximum 10 letters length 
• The English alphabet has 26 characters. 

Output

The output will contain the code of the given word, or 0 if the word can not be codified.

Sample Input

bf

Sample Output

55


题意:输入一个字符串,判断其相应的字典序,字典序从a=1开始,ab=27,bf=55….

输入的字符串必须为升序,否则为非法字符串,则输入0并结束程序。

最长输入十个字符,输出字符串相应的字典序!

PS:不要循环输入字符串

 

若字符串长度为1,则可知一共有C(1,26)种;

若字符串长度为2,从26个字符串中任选两个不同的字符,有C(2,26)种;

以此类推……

 

 

思路:首先判断该字符串是否为升序字符串,若为降序字符串,输出0并结束程序。

其次,求出长度小于len的所有字符串的字典序和!

再者求出长度等于len的字符串的字典序和。

#include <stdio.h>
#include <string.h>

int c[30][30];

void Init(){
	int i,j;
	
	for(i = 0; i <= 26; i ++){
		for(j = 0; j <= i; j ++){
			if(!j || i == j)
				c[i][j] = 1;
			else
				c[i][j] = c[i - 1][j] + c[i - 1][j - 1];
		}
	}
}

int main(){
	char str[15];
	int i,j,len,count = 0;
	
	Init();
	
	gets(str);//注意不要循环输入字符串!!! 
		
	len = strlen(str);
		
	for(i = 0; i < len - 1; i ++){
		if(str[i + 1] <= str[i]){//判断是否为非法字符串,若为非法字符串则输出0并结束程序 
			printf("0\n");
			return 0;
		}
	}
	//如果从i= 0开始,则最后输出不需要自加	
	for(i = 0; i < len; i ++){//计算出现1~len-1个字符 
		count += c[26][i];
	}
		
	for(i = 0; i < len; i ++){
		char ch;
			
		ch = (!i) ? 'a':str[i-1] + 1;//判断是否为第一个字符,且根据升序原则,必须要比前一个字符大 
			
		while(ch < str[i]){
			count += c['z' - ch][len - i - 1];
			ch ++;
		}
	}
		
	printf("%d\n",count);//再计算上本身 
	
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值