HDU1253 胜利大逃亡 (BFS)

23 篇文章 0 订阅

胜利大逃亡
Time Limit:2000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

Ignatius被魔王抓走了,有一天魔王出差去了,这可是Ignatius逃亡的好机会. 

魔王住在一个城堡里,城堡是一个A*B*C的立方体,可以被表示成A个B*C的矩阵,刚开始Ignatius被关在(0,0,0)的位置,离开城堡的门在(A-1,B-1,C-1)的位置,现在知道魔王将在T分钟后回到城堡,Ignatius每分钟能从一个坐标走到相邻的六个坐标中的其中一个.现在给你城堡的地图,请你计算出Ignatius能否在魔王回来前离开城堡(只要走到出口就算离开城堡,如果走到出口的时候魔王刚好回来也算逃亡成功),如果可以请输出需要多少分钟才能离开,如果不能则输出-1. 


Input

输入数据的第一行是一个正整数K,表明测试数据的数量.每组测试数据的第一行是四个正整数A,B,C和T(1<=A,B,C<=50,1<=T<=1000),它们分别代表城堡的大小和魔王回来的时间.然后是A块输入数据(先是第0块,然后是第1块,第2块......),每块输入数据有B行,每行有C个正整数,代表迷宫的布局,其中0代表路,1代表墙.(如果对输入描述不清楚,可以参考Sample Input中的迷宫描述,它表示的就是上图中的迷宫) 

特别注意:本题的测试数据非常大,请使用scanf输入,我不能保证使用cin能不超时.在本OJ上请使用Visual C++提交. 

Output

对于每组测试数据,如果Ignatius能够在魔王回来前离开城堡,那么请输出他最少需要多少分钟,否则输出-1. 

Sample Input

1
3 3 4 20
0 1 1 1
0 0 1 1
0 1 1 1
1 1 1 1
1 0 0 1
0 1 1 1
0 0 0 0
0 1 1 0
0 1 1 0

Sample Output

11

#include <stdio.h>
#include <string.h>
#include <queue>

using namespace std;

int map[55][55][55],visited[55][55][55];
int dir[6][3] = {{1,0,0},{-1,0,0},{0,1,0},{0,-1,0},{0,0,1},{0,0,-1}};
int a,b,c;

struct node{
	int x,y,z;
	int step;
};

int Judge(int x, int y, int z){
	if(x >= 0 && x < a && y >= 0 && y < b && z >= 0 && z < c)
		return 0;
	return 1;
}

int bfs(int t){
	queue <node> Q;
	node temp,next;
	
	temp.x = temp.y = temp.z = temp.step = 0;
	
	Q.push(temp);
	
	while(!Q.empty()){
		temp = Q.front();
		Q.pop();
		
		if(temp.x == a - 1 && temp.y == b - 1 && temp.z == c - 1)
			if(temp.step <= t)
				return temp.step;
			else
				return -1;
		
		for(int i = 0; i < 6; i ++){
			next = temp;
			
			next.x += dir[i][0];
			next.y += dir[i][1];
			next.z += dir[i][2];
			
			if(Judge(next.x,next.y,next.z) || visited[next.x][next.y][next.z] || map[next.x][next.y][next.z])
				continue;
			
			next.step = temp.step + 1;
			visited[next.x][next.y][next.z] = 1;
			Q.push(next);			
		}
	}
	return -1;
}

int main(){
	int k,t;
	
	scanf("%d",&k);
	
	while(k --){
		scanf("%d%d%d%d",&a,&b,&c,&t);
		
		memset(visited,0,sizeof(visited));
		
		for(int i = 0; i < a; i ++){
			for(int j = 0; j < b; j ++){
				for(int m = 0; m < c; m ++){
					scanf("%d",&map[i][j][m]);
				}
			}
		}
		
		int ans = bfs(t);
		
		printf("%d\n",ans);
	}
	
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值