POJ1753 Flip Game (DFS)

23 篇文章 0 订阅

Flip Game
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 43237 Accepted: 18651

Description

Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it's black or white side up. Each round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules: 
  1. Choose any one of the 16 pieces. 
  2. Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).

Consider the following position as an example: 

bwbw 
wwww 
bbwb 
bwwb 
Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become: 

bwbw 
bwww 
wwwb 
wwwb 
The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal. 

Input

The input consists of 4 lines with 4 characters "w" or "b" each that denote game field position.

Output

Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it's impossible to achieve the goal, then write the word "Impossible" (without quotes).

Sample Input

bwwb
bbwb
bwwb
bwww

Sample Output

4

Source


题目描述:在一个4*4的棋盘上,有16个方格,每个方格上面都有一枚棋子,棋子一面是白色一面是黑色,每次翻转一个棋子的时候周围的棋子也会被翻转,求能使棋盘上的棋子变成清一色翻转的最少次数。

问题分析:对于一个棋子来说,如果翻转偶数次,就等价于翻转0次,如果翻转奇数次,就等价于翻转1次。因此可以得出,翻转的次数最多不超过16次,因为翻转的次数如果 超过16次,则必然存在翻转两次以及以上的翻转次数,就等价于翻转一次或者零次。对于每个棋子,有翻转或者不翻转两种选择方法,所以共有2^16种选择。


#include <cstdio>
using namespace std;

char chess[6][6];
int a[4][4],dir[5][2]={0,0,1,0,-1,0,0,1,0,-1};
int flag,step;

int judge_chess(){
	for(int i = 0; i < 4; i ++){
		for(int j = 0; j < 4; j ++){
			if(a[i][j] != a[0][0])
				return 0;
		}
	}
	return 1;
}

void flip_chess(int r, int c){
	int x,y;
	for(int i = 0; i < 5; i ++){
		x = r + dir[i][0];
		y = c + dir[i][1];
		if(x >= 0 && x < 4 && y >= 0 && y < 4)
		a[x][y] = 1 - a[x][y];
	}
}

void dfs(int r, int c, int deep){
	
	if(deep == step)  //当达到要翻转的次数时,判断棋盘上的棋子是否是清一色。 
		flag = judge_chess();
		
	if(flag || r >= 4)  //如果已经存在清一色或者超过边界,则结束 
		return;
		
	flip_chess(r,c);  //对棋子进行翻转 
	if(c < 3)        //判断c+1是否会超过边界 
		dfs(r,c+1,deep+1);
	else
		dfs(r+1,0,deep+1);//超过边界则换下一行。 
		
	flip_chess(r,c); //再次进行翻转,等价于对该棋子不进行翻转。因为每个棋子有两种选择,翻转或者不翻转。 
	if(c < 3)
		dfs(r,c+1,deep); 
	else
		dfs(r+1,0,deep);
}

int main(){
	for(int i = 0; i < 4; i ++){
		scanf("%s",&chess[i]);
		for(int j = 0; j < 4; j ++){
			if(chess[i][j] == 'b')
				a[i][j] = 1;
		}
	}
	
	for(step = 0; step <= 16; step ++){ 
		dfs(0,0,0);
		if(flag)
			break;
	}
	if(flag)
		printf("%d\n",step);
	else
		printf("Impossible\n");
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值