POJ 1753 Flip Game

Flip Game
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 38316 Accepted: 16665

Description

Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it's black or white side up. Each round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules:
  1. Choose any one of the 16 pieces.
  2. Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).

Consider the following position as an example:

bwbw
wwww
bbwb
bwwb
Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become:

bwbw
bwww
wwwb
wwwb
The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal.

Input

The input consists of 4 lines with 4 characters "w" or "b" each that denote game field position.

Output

Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it's impossible to achieve the goal, then write the word "Impossible" (without quotes).

Sample Input

bwwb
bbwb
bwwb
bwww

Sample Output

4


有4*4的正方形,每个格子要么是黑色,要么是白色,当把一个格子的颜色改变(黑->白或者白->黑)时,其周围上下左右(如果存在的话)的格子的颜色也被反转,问至少反转几个格子可以使4*4的正方形变为纯白或者纯黑?

主要思路如下:

1.对于每个格子,它要么反转0次,要么反转1次(当然,它的邻格子也跟着反转),因为它反转偶数次和反转0次的效果是一样的,同理反转奇数次的效果和反转1次的效果是一样的。
2.由于只有16个格子,我们可以选择0个格子,1个格子,2个格子,3个格子......进行反转,总的选择情况为


3.当0个格子被反转时,看它是否为纯色,否则选择一个格子进行反转(有16种选择),看反转后是否为纯色,否则选择两个格子进行反转(有120种选择),看反转后是否为纯色......
4.只要"3过程"中有纯色出现,就停止"3过程",输出相应的被选择的格子个数,结束。如果16个格子都被翻转了,还是没变成纯色,则输出“Impossible”。


大神博客:http://www.cnblogs.com/shuaiwhu/archive/2012/04/27/2474041.html

代码部分:

#include <stdio.h>
char map[4][4];
bool judge()
{
	int i, x1, y1, x2, y2;
	for(i = 0; i < 15; i++)
	{
		x1 = i / 4;
		y1 = i % 4;
		x2 = (i + 1) / 4;
		y2 = (i + 1) % 4;
		if(map[x1][y1] != map[x2][y2])
			return false;
	}
	return true;
}
void change(int i)
{
	int x = i / 4;
	int y = i % 4;
	map[x][y] = (map[x][y] == 'b' ? 'w' : 'b');
	if(x > 0)
		map[x-1][y] = (map[x-1][y] == 'b' ? 'w' : 'b');
	if(x < 3)
		map[x+1][y] = (map[x+1][y] == 'b' ? 'w' : 'b');
	if(y > 0)
		map[x][y-1] = (map[x][y-1] == 'b' ? 'w' : 'b');
	if(y < 3)
		map[x][y+1] = (map[x][y+1] == 'b' ? 'w' : 'b');
}
bool DFS(int n, int num)
{
	if(n == 0)
	{
		if(judge())
			return true;
		else
			return false;
	}	
	for(int i = num; i < 16; i++)
	{
		change(i);
		if(DFS(n-1, i+1))
			return true;
		change(i);
	}
	return false;
}
int main()
{
	int i, j;
	bool flag = false;
	for(i = 0; i < 4; i++)
	{
		for(j = 0; j < 4; j++)
		{
			scanf("%c", &map[i][j]);
		}
		getchar();
	}
	for(i = 0; i <= 16; i++)
	{
		if(DFS(i, 0))
		{
			flag = true;
			break;
		}
	}
	if(flag)
	{
		printf("%d\n", i);
	}
	else
	{
		printf("Impossible\n");
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值