POJ1017 Packets (贪心)

 

Packets

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 55961 Accepted: 19057

 

Description

A factory produces products packed in square packets of the same height h and of the sizes 1*1, 2*2, 3*3, 4*4, 5*5, 6*6. These products are always delivered to customers in the square parcels of the same height h as the products have and of the size 6*6. Because of the expenses it is the interest of the factory as well as of the customer to minimize the number of parcels necessary to deliver the ordered products from the factory to the customer. A good program solving the problem of finding the minimal number of parcels necessary to deliver the given products according to an order would save a lot of money. You are asked to make such a program.

Input

The input file consists of several lines specifying orders. Each line specifies one order. Orders are described by six integers separated by one space representing successively the number of packets of individual size from the smallest size 1*1 to the biggest size 6*6. The end of the input file is indicated by the line containing six zeros.

Output

The output file contains one line for each line in the input file. This line contains the minimal number of parcels into which the order from the corresponding line of the input file can be packed. There is no line in the output file corresponding to the last ``null'' line of the input file.

Sample Input

0 0 4 0 0 1 
7 5 1 0 0 0 
0 0 0 0 0 0 

Sample Output

2 
1 

Source

Central Europe 1996

 

题目链接:http://poj.org/problem?id=1017

 

题意:有1*1,2*2,3*3,4*4,5*5,6*6的邮件6种,高度都为h,现在要把这些邮件放在一个6*6,高度为h的包裹里,求最少的包裹数目。

思路:首先放6*6的,一个即可装满,

其次放5*5的,需要11个1*1的才能够装满。

然后放4*4的,需要5个2*2的装满,2*2的不够则放1*1的

然后再放3*3的,需要4个3*3的,不能装满则放2*2,1*1

放2*2的,9个就能够装满,不满则放1*1

最后放1*1,36个就能装满。

 

AC代码如下:

 

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

int a,b,c,d,e,f;

int main(){
	while(~scanf("%d%d%d%d%d%d",&a,&b,&c,&d,&e,&f)){
		if(!a && !b && !c && !d && !e && !f) break;
		int ans = 0;
		if(f) ans += f;   //为6*6的一个箱子即可装满 

		ans += e;  a = max(0,a - 11*e); //5*5的需要11个1*1的补满 

		ans += d;  //4*4的需要2*2的或者1*1的补满,2*2不够则用1*1的 
		if(b - 5 * d < 0) a = max(0,a - 4 * (5*d - b));
		b = max(0,b - 5*d);
		
		ans += (c+3)/4; c %= 4; //3*3的4个能够装满,剩下的用1*1或者2*2补满 
		if(c == 1){//剩下1个3*3的 ,最多放5个2*2的,其余1*1的 
			if(b < 5) a = max(0,a - 7 - (5-b)*4);
			else a = max(0,a - 7);
			b = max(0,b - 5);
		} 
		else if(c == 2){//剩下2个3*3的,最多再放3个2*2的,剩下全为1*1 
			if(b < 3) a = max(0,a - 6 - (3-b)*4);
			else a = max(0, a - 6);
			b = max(0, b - 3);
		}
		else if(c == 3){//剩下3个3*3的,最多再放1个2*2的,剩下为1*1 
			if(!b) a = max(0,a - 9);
			else a = max(0,a - 5);
			b = max(0,b - 1); 
		}
 
		ans += (b + 8) / 9; b %= 9;//放2*2的,不够怎用1*1来补 
		if(b) a = max(0,a - (9 - b) * 4);
		
		ans += (a + 35) / 36;//放1*1的箱子 
		
		printf("%d\n",ans);
	}
	return 0;
}

 

 

 

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值